Syncing App With Self Hosted Site


#1

Hello

This is probably a pretty easy answer I just can’t seem to find it.

I am self hosting Rocket chat and was curious how to find the server name so that I can sync it with the mobile app and mac app?

I tried putting my domain and it didn’t seem to work. Am I overlooking something?

Thanks


#2

Did you install it on the same server as your website? Is it a VPS or a dedicated server?

Does your hostingplatform allow the usage of port 3000?


#3

Yeah I did install it as the same as the site.

I’m hosting with SSDNodes and I’m unsure if it allows for port 3000. I could find out, but they promote self hosting rocket chat with them so I imagine it does.

I was able to sync up with the Mac OS client. It brought up a SSL notification (I use LetsEncrypt) that I accepted and it synced up. I haven’t been able to do it with the iOS app because it doesn’t end up showing the notification.
Do I need to fix my SSL certificate do you think?

I’m also not receiving emails through the system; whether it be by clicking the ‘Forgot Password’ links etc.
Is there something I must do with the VPS to allow for emails to be sent?

I appreciate the help.


#4

I don’t think the app works unless you have it setup with https. I tried to get it working with http port 3000 and wasn’t successful.


#5

I am using the Lets Encrypt service myself on my chatbox. Works perfectly.

I also had problems receiving the messages. Make sure that you select custom messages. When I used the default messages I had problems receiving mails too.

Also make sure that you enter the IP address of your chatbox in the spf dns record. Or else your provider will think the messages are spam.


#6

Sorry for the slow reply, I appreciate your responses.

I did just get my SSL enabled on the site but when I try to connect via the mobile app client it gives me this error: ‘OOPS! could not connect to this server!’

Is there something else I must do?

Also in regards to the email messages, where do I go to ‘select custom messages’?

Is that in the settings?


#7

Can you reach the hostname with a webbrowser? I have also setup port 80 to point to the RC installation.

The app only works with https, so how did you secure the website?


#8

Yeah I can login from a web browser and I was able to connect with the mac client as well.

My SSL certificate just needed to be renewed through Lets Encrypt so we took care of that.

I thought the Rocket Chat+ iOS app would work ok after this, but it still just gives an error that it can’t connect.

I have someone helping me out with everything in regards to the server. So I may need to tell them about the port 80 set up?


#9

No the port 80 setup is used to make it easier for people to connect with a webbrowser. If port 3000 is not blocked in your setup you should be able to connect with the IOS app too. I don’t think it is blocked because you can connect with the mac client and I think that also connects to port 3000 by default?

If you pm me the hostname of your setup I will be more than willing to test if I can connect with android app. I haven’t got an iPhone, but at least you can check if connecting with a mobile phone is a problem.


#10

Having the same issue on a new install on an Ubuntu 18.4 LTS box. Just got our ssl cert installed and both web and desktop clients connect. Just times out via iphone.


#11

Do you have WebSockets enabled in your server?