Can’t connect to rocket chat instance with iOS


#1

Firstly, setup:
Raspberry pi 3 with latest Ubuntu core and running the latest snap version for raspberry pi of rocket chat. As of writing.
Rocket chat is more or less basic standard installation, nothing custom, with self signed certificate.
I could not use a proper certificate from the built in service because the URL is a sub domain from open dns, which can not be issued https certificates.
I can connect to the server using the url from a browser, from the desktop application and from the android application. But I can not with the iOS app, not even with the latest released today. It just says “oops the url you entered was invalid etc”.

Is it because of the self signed certificate? I have a feeling it is but I don’t know what to do about it. I also heard something about web sockets but I can’t find more info about it.
Any suggestions?


#2

Some additional information: Caddy has been enabled with the same settings as suggested by the documentation. Though I found out that when connecting with https port 3000 is not used but 2015 instead, which I had to also configure in the routers port forwarding (port 443 to port 2015 on the rocket chat server).
Also there might be some trouble with web sockets but I have no idea how to check if that is the problem at what to do. Some help would be greatly appreciated as information is very lacking.


#3

@frederik.t Thanks for opening the issue! Let me ask you a few things:

  1. Are you running the iOS version from the store?
  2. Is your server public? Can you provide me the URL?
  3. Does your server supports a valid SSL certificate (not self-signed)?

#4

Thank you for reply. I do not know if it’s an actual issue, or me not understanding rocket.chat completely.
1: I have tested with rocket.chat+ version 2.1.0 and 2.1.1 that was just released.
2: I can send you a PM if that’s possible. If not I will edit this message.
3: Like I said it’s a snap installation on ubuntu core, where I have enabled caddy. I tried first with the automatic ssl certificate from letsencrypt thats built into caddy, but eventually figured out it didn’t work because right now I am using a subdomain from opendns, and apparently letsencrypt have disabled handing out certificates for opendns subdomains. Thats why I switched to a self signed certificate. I will some point in the future get my own domain, but thats a while off as I learn about it right now :wink:


#5

After a brief talk with @rafaelks it IS the self-signed certificate that is causing trouble. Just wanted to put this here for anyone else.
AFAIK support of self-signed certifactes in the iOS app is currently being worked on.