iOS-App vs my Server


#1

Hello Community,

I have a problem connecting to my Rocket.Chat instance via iOS-App.
It is working via Safari-Browser, via Android-app and via Windows-Client.

The certificate is not self signed and the full cert-Chain is available.

For those who want to try: server.domain.tld [Edit: removed after solving of problem]

I even tried to import all the Certs in the chain to the iPhone, but its still not working…

I do not know what to do…
can someone help please.
Thanks
MSDD


#2

From the message, it looks like your server is not supporting HTTPS connections the way the app is expecting. It requires TLS v1.2 at minimum.


#3

Hi rafael,

Danke for your reply,

based on SSl-Labs test: https://www.ssllabs.com/ssltest/analyze.html?d=server.domain.tld
TLS 1.2 is availabel and enabled…

do you see any way to find out what specifically should be enabled?

Cheers,
MSDD


#4

You can check on this report what you can improve in your SSL: https://www.ssllabs.com/ssltest/analyze.html?d=chat.der-immo-tip.de.


#5

hi,

thats exactly what I did, I posted the very same URL 2h ago.
AFAIK the report says, that TLS V1.2 is enabled, but the problem still exists. Is there a console or a logfile written by the iOS app, so that I can find out better whats wrong?

thanks
MSDD


#6

Hi,
For me your server works on iOS with Rocket Chat App 3.2.0.
Have a nice weekend…


#7

hi,

yeah I found a solution this afternoon.
I had to enable certain cipher suites (TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) and I had to give them a higher priority…

…so that case can be closed!

Thanks everyone