Rocket.Chat docker server running but page stuck on the three dots loading page

I found the cause of the issue (or atleast mine). Apparently even when you run docker compose down, it does not totally wipe the mongodb data. I originally had run the docker compose without changing the ROOT_URL.

After hours and hours of searching, I finally stumbled upon the answer. Run the command “docker compose down --volumes” while the containers are running and this will wipe the mongodb.

Make sure your .env file is correct and run “docker compose up -d” again and it should change the site URL to what you have listed in the .env file.

Hope this helps!

2 Likes

I had the same issue. I removed the containers but had to also include a flag to delete the volume for the mongodb since I initially created the containers before I made the .env file.

To clear the volume and start over from scratch (your compose .yml and .env file should be safe, just make sure the ROOT_URL is what you want it to be), run

“docker compose down --volumes”

and you should see not only do the containers and network bridge get destroyed, but also the volume used for the mongodb.

From there run “docker compose up -d” and either check the rocketchat log or navigate to the URL and see if that works. Hope this helps!

1 Like

Thanks for your answer!!

I finally find out, that indeed the URL is written into the dB and you need to update it or use your trick to make it work.

Thanks a lot!

Cheers!

1 Like

I’m having the same issue but I’m running in a snap, not docker. What steps should I take?

Got the same problem

It looks like it has been fixed in 6.4.4 (or maybe even 6.4.3). You can either wait for that version to be pushed to 6.x/stable OR (like me) you can update the channel for your rocket chat instance with the following command:

sudo snap refresh rocketchat-server --channel=6.x/edge

1 Like

That fixed it for me, kudos to you sir! :wink:

Unfortunately, snap 6.4.4 does not fix it for me. Still looking at the 3 dots…
I dont hope the database is corrupted and cannot be fixed?

This did not help me either, anymore tips

Resolved by changing the siteurl. Somehow, it included the port as well as the port field.

I.e., siteurl from https://chat.mydomain.com:3000 to https://chat.mydomain.com

Behind HAProxy, snap installation.

Here’s how I solved the issue :

Open a bash in the docker ID of your mangodb container (replace x12345678 with your id)
docker exec -it x12345678 bash

open mongo by typing:
mongo

type use rocketchat to switch to the rocketchat database
use rocketchat

type db.rocketchat_settings.update({“_id” : “Site_Url”},{$set:{value:“”}})
example:

db.rocketchat_settings.update({“_id” : “Site_Url”},{$set:{value:“https://chat.mydomain.com”}})

That’s it :slight_smile:
Cheers

1 Like

Someone has a solution for snap version? I tried to refresh snap to 6.4.4 but it dosen’t work for me.

My environment is snap as well. I believe mine is working now. not totally sure what I done since I was fighting this since last Friday trying everything I know and Google LOL. But what seem to work was putting the ip address in the site url. I know that is not ideal but if that is what it takes I was here for it. Hope this helps…

Hello, can you give me any advice how you changed the site url?
I´m rather new to rocket.chat, sorry

sudo snap set rocketchat-server siteurl=https://your.domain

Sadly it dosen’t work for me.

I tried to sudo mongo, but it says:
“./mongo: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory”
Is there anything wrong with my snap?

I also had to install the ubuntu-desktop on the server and once that was done I was able to use localhost:3000 and saw everything was running properly. then I went in the settings ,General and changed the site url.

But the Port must be icluded in the Site URL in Setting, yes?
for example: http://myserver:3000

Tried to include the port? (https://yourdomain:3000)

Yes, I believe so as well