Latest RocketChat Snap - permanently loading (3 dots)

hello,

i had the same issue. i set up an ssh tunnel to the server like so:

ssh -L 3000:localhost:3000 root@[HOSTNAME].[DOMAIN]

then i logged into rc one time through the ssh tunnel.
so browser-address “localhost:3000”

i could log in through the ssh tunnel and after this one login suddenly it worked again without ssh tunnel.

in my case through a reverse proxy with caddy.

I have the same issue, even just connecting via ip address. When I check the logs, it’s an issue with the mongodb snap. Here’s an example of the error.

{“t”:{“$date”:“2023-10-23T12:17:21.096-05:00”},“s”:“I”, “c”:“STORAGE”, “id”:22430, “ctx”:“Checkpointer”,“msg”:“WiredTiger message”,“attr”:{“message”:“[1698081441:96461][928:0x7f9fa9334700], WT_SESSION.checkpoint: [WT_VERB_CHECKPOINT_PROGRESS] saving checkpoint snapshot min: 98734, snapshot max: 98734 snapshot count: 0, oldest timestamp: (1698081133, 1) , meta checkpoint timestamp: (1698081433, 1) base write gen: 4762637”}}

It seems that people are having this issue both on the snap version and docker versions of Rocket.chat… Clearly something went wrong with the latest updates.

Is this going to be looked into by the Rocketchat team? Or how do we collectively submit a report to them?

1 Like

Did my very first Rocket.Chat deployment yesterday. Version 6.4.2 on Ubuntu 22.04 virtual machine via snap.

Had to install a GUI to find that http://localhost:3000 is actually functioning. Tried changing the url to http://server_IP:3000 in the settings and getting the the infamous permanent loading three dots from both the server itself as well as any other machine.

Any fixes on the horizon?

No idea. Do devs ever check this forum?

Fix described here by switching to a dev branch version:

Thanks to @csteaderman

I have tried a new install with this and updated a current system and its a no go. Is there anymore insight on this issue. Thanks

Resolved by changing the siteurl. Somehow, it included the port as well as the port field.

I.e., siteurl from https://chat.mydomain.com:3000 to https://chat.mydomain.com

Still a no go for me

Without a portnumber, i cant get a connection at all: “no valid server found at the url”
snap install, http only, no proxy.

Personally, i can access the snap server only internally (both from the desktop app and from the browser) from the http://localhost:3000 address only. Internally, If i try to access it from the server’s URL (http://myip:3000) then i come up with the permanent loading problem. Same goes when i try to access it from another browser or desktop app inside or outside the local network. The strange thing is that i have complete access from my mobile network when using the Android app using the http:/myip:3000 address.

I installed Rocket Chat 6.4.5 on a fresh VM running an Ubuntu 22.04 server. Everything as instructed at Deploy with Ubuntu - Rocket.Chat Docs. Unfortunately, I still have problems with page loading and three dots. Can someone help with that?

Try adding ubuntu-desktop then going to the admin page locally then change the site url to the ip address:3000.

I can’t open localhost:3000 locally using Ubuntu-desktop, I have 3 dots. After that, I changed the site URL with “sudo snap set rocketchat-server siteurl=http://IP.addres:3000” but it didn’t help. I also tried without port number in siteurl.

So just so I understand correctly your installation has not worked from the start correct.

Now I have a third VM with Rocketchat. The first one worked very well until the three dot problem occurred. But the next two didn’t work from the start. I install Ubuntu-desktop on all these VMs and I can’t open the site with http://localhost:3000 or http://ip:3000 (3 dots).

Have you tried installing with snap?

As i can understand, all of us here have the same issue having deployed Rocketchat using Snaps.

1 Like

I believe so, It has came back on my server and it was working perfectly. So I am not sure what is going on. Is there any paid support for this from anywhere?

Twice with snaps (the first one worked perfectly until the 3 dot issue occurred) and one manual install.