Not able to connect self-hosted to Rocket Chat Cloud

Description

Want set up Rocket Chat for testing purposes for a public charity. It runs in a docker container, can be reached via the local network as well as rocket.mydomain.com and almost everything works. Just the connection to the Rocket Cloud won’t… and, by extension, the marketplace and app features.

Connected and removed the workspace various times within the cloud console and re-registered it - online as well as manually. Synced my Rocket Chat instance before re-registering it each time. But im am still stuck with this error message:

The Rocket.Chat Workspace you are attempting to sign into is currently associated with a different Rocket.Chat Cloud account than the one you are signed in with. (09f1ef34-7813-40a8-926d-3498e1827f2a)

Even tried to delete the workspace infos from the MongoDB database like someone suggested in this thread.

Server Setup Information

  • Version of Rocket.Chat Server: 3.8.1
  • Operating System: Unraid 6.8.3
  • Deployment Method: Docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: v12.18.4
  • MongoDB Version: 4.4.2
  • Proxy: Nginx
  • Firewalls involved: Build-In Firewall of my Fritzbox 6591 Cable

Any ideas what I could try to get that thing running are greatly appreciated.

1 Like

I have the same issue. Did you ever solve this?

No, not jet. Kind of frustrating. I’m thinking about using Mattermost instead

Hi! I am having the same problem :frowning:

I have the same issue. Did you ever solve this?

I seem to have the same issue. Currently running snap install of Rocket.Chat
Version 2.4.11

Apps Engine Version 1.11.2
Database Migration 170
Database Migration Date December 20, 2020 9:10 PM

Tried to change the track and server booted and RC worked fine, but then no notifications … Introducing SNAP Tracks!

No, not yet. And since you do not seem to get any help here, I switched to Mattermost in the meantime… which works fine for me.

still get this error
Error
The Rocket.Chat Workspace you are attempting to sign into is currently associated with a different Rocket.Chat Cloud account than the one you are signed in with. (8c6deb2a-7c6c-47c4-b028-908de1eeda1b)
I have tried the Push, Setup Wizard, and Connectivity Services. Each time I get this is after I try and change the channel…
snap switch rocketchat-server --channel=3.x/stable
The switch works, and all looks good in logging… the only thing I can’t do here is get this alerting of messages through the rocket.chat gateway to the phones… This has gotten to be absurdly complicated fellas and gals!