Unable to register self-hosted workspace with Rocket.Chat Cloud

Description

Hey there guys,

i’m trying to register a self-hosted Rocket.Chat server with the Rocket.Chat cloud so I can use the marketplace. However everytime I want to register it the site just won’t let me.
If I use the option with internet access, I simply can’t click continue, the button simply does nothing.
If I use the option without internet access, I enter the code generated by my installation but as soon as I click continue, I just get an error that the code I pasted seems invalid (500 error in the background to the api). However when I reload the site, the server is there in the registered state, but it is not registered on my installation.
This is the json payload that’s beeing sent to the api:

  1. address: “https://team.xxx.com
  2. deploymentMethod: “snap”
  3. deploymentPlatform: “selfinstall”
  4. hosted: false
  5. name: “Rocket.Chat”
  6. uniqueId: “v9kJYTt72Y6SGeF6v”
  7. version: “3.1.1”

This is driving me nuts, I’ve tried to register it multiple times today and I’ve never got any return code to enter in my installation to finish the registration process. Now I have six workspaces registered under the same domain in my cloud account that don’t work, however I also can’t delete them (is that on purpose or am I missing something?). I even tried to register the server under a completely different domain, even that did not help, I’ve now got two workspaces registered under that name as well.
A reinstall of the server has also been tried, to get a new uniqueId, unfortunately also no effect.

I’m currently at a loss as to how to continue with this problem. Can anybody here shed some light
on what I might be doing wrong? Also, is there a possibility to remove workspaces from the cloud console again if they aren’t used anymore, or (in my case) wrongly registered? It’s driving me nuts that I now have so many wrongly registered workspaces in there, with no way to delete them.

Any help would be much appreciated!

Server Setup Information

  • Version of Rocket.Chat Server: 3.1.1
  • Operating System: Ubuntu 18.04.4 LTS
  • Deployment Method: snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog: active
  • NodeJS Version: v12.16.1
  • MongoDB Version: 3.6.14
  • Proxy: nginx
  • Firewalls involved: none at the moment

Any additional Information

To my knowledge none. I followed the simple setup process of the snap package and the first configuration website dialog.

Thanks in advance!