Meteor and Node version differences, how to address?


I have tried installing RocketChat many times, on my local home VMware server, on a fully updated version of Ubuntu 20.04, and I haven’t had any issues. I am now trying to create an install on an Oracle Cloud VM, and following the tutorial located here: and for the life of me, I cannot figure out why I keep getting this error:

● rocketchat.service - The Rocket.Chat server Loaded: loaded (/etc/systemd/system/rocketchat.service; enabled; vendor preset: enabled) Active: failed (Result: exit-code) since Wed 2022-04-27 17:52:38 UTC; 12s ago Process: 12930 ExecStart=/usr/local/bin/node /opt/Rocket.Chat/main.js (code=exited, status=1/FAILURE) Main PID: 12930 (code=exited, status=1/FAILURE) `` Apr 27 17:52:38 xxxx-test systemd[1]: Started The Rocket.Chat server.

Apr 27 17:52:38 xxxx-test rocketchat[12930]: Meteor requires Node v14.0.0 or later.

`Apr 27 17:52:38 xxxx-test systemd[1]: rocketchat.service: Main process exited, code=exited, status=1/FAILURE` `Apr 27 17:52:38 xxxx-test systemd[1]: rocketchat.service: Failed with result 'exit-code'.`

My node version is: v12.22.12 and in the tutorial it does mention:

installing a different version of node than the base version installed causes conflicts with Rocket.Chat in Ubuntu 20.04. You should only install a version that is same as the base version or create a symbolic link to the base version

I do think that is the issue, I am just confused though. If I try to update Node, it ends up not working. I am not familiar with Node, or Meteor. Google results mention in a few spots to use zodern/meteor? I just cannot get around this, and would appreciate any suggestions! I rarely have ever have to ask for help, so I can provide any other information necessary!

Server Setup Information

  • Version of Rocket.Chat Server: 20.04
  • Operating System: Ubuntu
  • Deployment Method: Manual
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: V12.22.12
  • MongoDB Version: V4.4.13
  • Proxy: nginx
  • Firewalls involved: Oracle Cloud VM

Any additional Information

Hi! Welcome to our friendly forum :slight_smile:

Do you have any hard requirement to install it manually?

Can you use docker or k8s?

We strongly suggest this approach, as it will save you all the dependency problems (like this one) that will eventually arise.

1 Like

I have not! But I can most definitely try! I did tray Snap, and I believe I had issues with that, so I had wanted to do everything myself. I have never used Docker, but familiar, k8 - not familiar.
I will research those options!

1 Like

Thanks again for the info!
After much hasslage, primarily with Oracle cloud and Ubuntu 20.04 with ‘ufw’ I was finally able to get an instance working, using Docker! Seems like alot of my issues went away disabling ufw, and replacing with ‘firewalld’ and creating rules using that. I am not 100% sure this was the only solution, because I tried so many things, I was able to get node and meteor to play nicely, and proper port forwarding in all the areas of the Oracle cloud instance and Ubuntu!
Thank you!

1 Like