Can't install app form marketplace, stuck in an authentication loop

Description

When i try to install an app from the marketplace the system ask me to login,
but i try to login from the specified menu it tells me i already am:


when i click on connect to rocketchat cloud i’m stuck in an authentication loop that always gets me back to the login screen. while i can connect to https://cloud.rocket.chat/ without problem from my browser.
i already tried syncing: sync ok but not working
i also tried to disconnect/reconnect without luck

Server Setup Information

  • Version of Rocket.Chat Server: 2.4.9
  • Operating System: Ubuntu 18.04
  • Deployment Method: tar
  • Number of Running Instances: 2
  • DB Replicaset Oplog: mongodb://user:pass@server1name:27017,server2name:27017/local?authSource=admin&replicaSet=rsname"
  • NodeJS Version: v8.17.0
  • MongoDB Version: 4.0.16
  • Proxy: nginx
  • Firewalls involved: Palo Alto

Any additional Information

nothing in the logs
both instance are connected on the info page
don’t see anything blocked by the firewall to/from the instance ip, the proxy ip or the public ip

the devtools are showing me an error 400: