Workspace registration not working


When trying to set up a rocket chat instance, I receive an email with the title “Verify your email to register your workspace”.

It contains instruction to go to
in order to verify the workspace.

However, that page is completely blank for me. Tried with multiple devices and browsers. The same process has worked for me in the past.

Server Setup Information

Hi! Welcome to our community! :hugs:

Can you see any outstanding logs in the browser console?

Are you registering it from the Setup Wizard or have choose to go stand alone and are try thru Admin > Connectivity Services?


Thanks for a quick response!

It’s through the setup wizard. I’m currently stuck in the process of setting it up.

No, there don’t seem to be any messages in the console.

If you just go to that url (even without trying to register) are you supposed to see a page? Because it’s completely empty for me. Is it not for you?

It may depend on your browser cache. Try using the incognito mode thing.

Also, try completing the setup without registering, and register it later.

Usually, the registration problems I see around is something related to the environment, or reverse proxy, etc.

Completing the setup without registering, then registering later from Connectivity Services did indeed work. Thank you!

1 Like