Registration in the Cloud Service Problem

I reinstalled my rocket chat server from scratch. I can’t seem to register it now post installation. My Connectivity Services screen acts like I am connected, but it won’t let me register the server.

On the cloud service, it says I have no workspaces.

I think that because I did not initially register the workspace, the server has some information pointing it to the wrong place. Anytime that I try to add an app in the marketplace, I get an authorization error like the one pictured. How can I correctly register this new server?

Hi, I have seen this occur before.

So, I believe you need to the following:

Disconnect your server from the cloud
Got to your workspace and make sure there are no servers connected
Connect again and resync.

I believe there might be an issue in certain circumstances if you have tried to change domains or email addresses.

Let us know if the above fixes it - if not we’ll speak to support.

I had disconnected the server from the cloud. The work space said it was not connected. I could never get the number to register it again. I nuked the server and reloaded it from scratch. This time it registered, but not by my domain name and just by the name “rocketchat.server” and so the marketspace would not work. While trying different commands, the server gave me a 402 error. I restarted the server and still got a 402 error. I think part of the reason might be that I am running behind NginX Proxy Manager and Rocket Chat is trying to do NginX proxy behind my main NginX proxy. I have 28 other self hosted instances of other programs that don’t have this issue. After the repetitive 402 issue, I nuked the server and rebuilt from scratch again.

This time the server registered in the cloud and the marketplace worked! However, after two hours the Rocketchat server went into 402 errors again. I’ve decided to go try Zulip instead. I have another friend that I set up Rocketchat for and he does not have NginX proxy manager his worked much better but this morning it too is throwing 402 errors. Sounds like the product still has some fundamental issues to work out. I’ll try it again sometime after more updates. Thanks!


I am sorry to here about your issues. We would have been happy to work through them with you.

You do have to set this up correctly and register a domain correctly. I am not sure that rocketchat.server is a resolvable domain !!

NginX Proxy Manager and Rocket Chat is trying to do NginX proxy behind my main NginX proxy

As you haven’t explained any of your setup it is hard to know why Rocket would be setting up its own nginx proxy. Snaps use Caddy. Docker can use Traefik but it isn’t necessary

I have no idea about a 402 error on a fresh install. I have never seen it before and it would have been good to try and debug this for you.

We clearly have a large number of installs and the large majority install without issue, but try as we might, we can’t always cater for absolutely every situation out of the box. But we are happy to help and learn!

We wish you well with your open source adventures and if you ever want to come back and try again with Rocket.Chat and its many advanced features then please do!