The Great Open Source Debate with Elastic, Gluu and GitHub 🎤 Oct 27

White screen on login when signing into different account

Hello

I am experiencing a log in issue in the Android version of RocketChat. I am not too familiar with Android development, so if any of the terminology is incorrect, please let me know and I’ll try to explain in more detail.

RC version 0.57.4

The log in/out function is governed by a different app, and once a user successfully logs in and navigates to the RocketChat app, a new app intent is created and RocketChat starts up in another app. The workflow is working upon first login, but if the user logs out on the main app and logs back in or signs in as another user and navigates back to the RocketChat app, a white screen is displayed and the user can’t access RocketChat. The only way the user can successfully log back in is by deleting the app/user cache for RocketChat. I’ve been diving through Android documentation to see if I can fix this myself, but so far everything I’ve tried has not worked. I’ve tried manually deleting the app/user cache instead of using the ActivityManager.clearApplicationUserData() as this closes the app after it is called which is not what I want in this situation.

My best guess is that, upon logout, the localRepository/sharedPrefs/interactors are not being cleared as when I attempt to login with a different user, the creds for the previous user are still stored in localRepository. What confuses me about this is that the issue still occurs when attempting to sign in again as the same user, as it should be pulling everything up from local cache. Debugging/checking the logs has not proven helpful either as there are no errors and everything seems to be “working as intended”.

If anyone can point me in the right direction for this issue, that would be much appreciated since I feel like I’m hitting a brick wall with this.

Released 6 Oct 2017

If you want help you are going to have to upgrade.

Simple as that.

Your version has not been supported for years and no one is going to be able to help you much on a version that old.

On top of which it sounds like yours is pretty heavily customised and that is just going to try and make giving you any help very difficult. And I bet you are still using the completely unsupported Android Kotlin app.

There are no easy solutions here I’m afraid.