Registering my workspace

Description

We recently upgraded our snap-installed rocket.chat server from 4 to 5, and then to version 6.2.2. Although after upgrading, the registration page still shows my workspace is registered, we can no longer sync up with the cloud.

Do I need to re-register my workspace?

To apply for an offline license, I tried to log on to https://cloud.rocket.chat/. But after providing my cloud username/password, I was brought to a blank web page.

Any hints are highly appreciated.

Server Setup Information

  • Version of Rocket.Chat Server: 6.2.2
  • Operating System: Ubuntu Linux 20.04
  • Deployment Method: snap
  • Number of Running Instances: 1
  • NodeJS Version: v14.21.2
  • MongoDB Version: 5.0.15 / wiredTiger (oplog Enabled)
  • Proxy: caddy
  • Firewalls involved: None

Any additional Information

Log message follows:

{“level”:50,“time”:“2023-06-02T01:55:22.668Z”,“pid”:4028,“hostname”:“bear.cs.nthu.edu.tw”,“name”:“System”,“msg”:“Failed to sync with Rocket.Chat Cloud”,“url”:“/client”,“cloudError”:{“error”:“internal_server_error”},“err”:{“type”:“Error”,“message”:“failed [500]{"error":"internal_server_error"}”,“stack”:“Error: failed [500]{"error":"internal_server_error"}
at makeErrorByStatus (server/lib/http/call.ts:59:9)
at server/lib/http/call.ts:168:19
at /snap/rocketchat-server/1557/programs/server/npm/node_modules/meteor/promise/node_modules/meteor-promise/fiber_pool.js:43:40”,“response”:{“statusCode”:500,“content”:“{"error":"internal_server_error"}”,“headers”:{“access-control-allow-headers”:“Content-Type, Authorization, Content-Length, Last-Event-ID, X-Requested-With”,“access-control-allow-methods”:“GET, PUT, POST, DELETE, OPTIONS”,“access-control-allow-origin”:“*”,“access-control-expose-headers”:“Content-Type, Authorization, Cache-Control, Expires, Pragma, X-powered-by”,“cache-control”:“private, no-cache, no-store, must-revalidate”,“connection”:“close”,“content-length”:“33”,“content-type”:“application/json; charset=utf-8”,“date”:“Fri, 02 Jun 2023 01:55:22 GMT”,“expires”:“-1”,“pragma”:“no-cache”,“vary”:“Accept-Encoding”,“x-fleet-version”:“v3.3.0-0b49723”,“x-powered-by”:“Rocket Fuel and Rocketeers”},“ok”:false,“data”:{“error”:“internal_server_error”}}},“msg”:“failed [500]{"error":"internal_server_error"}”}

Hi @siliconbear Please restart the workspace and try to reconnect to your server again. Because when you try to regenerate a token from http://cloud.rocket.chat, sometimes is required your instance be restarted in order to connect to the cloud again. Hope this info works for you.

Hi @lester.coyoy,

Thanks for the hint.

When trying to connect to the cloud, I was brought to a blank web page. If I use browsers to connect to cloud.rocket.chat, after providing my username/password, I was also brought to the same blank web page.

Is this as expected?

Thank you!

Hi @siliconbear what are the errors from console in Web Browser? Would be helpful as from Console as from Network tabs in Inspect option from the browser?

Additionally, you can manually try to clear the Cloud info in the DB (we need to do this to be able to reconnect the server to the Cloud account) using this command

db.rocketchat_settings.remove( {"_id": /Cloud_/}

IMPORTANT: Make sure to stop rocketchat service before to do this. To access the rocketchat db in snap, please follow this guide

After you do this, restart the rocket service.

Please let us know if it works.

Hi @lester.coyoy,

The errors in the browser are as follows. Do you think it’s a font issue with my local browsers? But I have tried quite a few browsers on both osx and windows. :frowning:

Will look into the db thing, but I’m worried I won’t have access to the webpage after doing that.

Thanks, again!

[Warning] 60 console messages are not shown.
[Error] [Report Only] Refused to load data:application/font-woff2;base64,d09GMgABAAAAAaGkAA0AAAAErjgAAaFFAAEAAAAAAAAAAAAAAAAAAAAAAAAAAAAAGoYEG4P1PhyBpkIGYACB53gKh9x4hq9NC6dYAAE2AiQDzywEIAWOHgeC7GNbz0K011Jku/v+2r0NrVbIJmwTmiGL0qgmmmhzjPaNgwPQUKtvKJ+Hfsj0n1cIRbSYaFq6PTfVMcqu3egQOPWT3+QMde4eFKty24Au3J6p3Jf9//////////////////eU/HjMrTcvycz/+UmTtElbeoZSKC3lKoLoinKorOsqru4FJQqFOfWahoCMWK4doqaFlkKdwmTlHOsa7eW1J43KvhgMo+5Z9FGE8YSVk5GY6kypx7wN+zpMF2GBgzwNIcyKVr3woegUKbr7motsqUaWznnigzE7NOQqj5T5lcFUeDUlav2uh4cd62q98aHGScFMicPACo3ozIgqU+HVhJvLIviqg20OrzjF…+MLQ047GBVhSpLS9T3RNyd4poJhiwVeroqsok0LeeqkqOzxVdRXO6S9EgvPMur9tZ5xCwjMjr6OHiH2p5pQYOAJs8yOuWeNU4+jQyQMImvCEBRwiVpGUAIRlCMrhwwRSUpqorRVYOuBkBUXVuMrp4oMiCVkzN1yhDFSZrVK0d5JSurmtWrRr0a0tQmzerVMUqq66lyBJ6xxejyoLoYbW2zenlYC6CsHgiH109V2mz9yb6LaCADESaUcSGVNtbllQNEmFDGhVQc0QeEkqMEBUUuKb6pPL1GAwBxenvr3WMU7ET+m4kkXqBRCJbkXa+2PDsYB0OSOiUxIvwMl9DlIBU8MxsUZG9296QY1QA6MUle9anp9wiodQ2CMKGMC6mMzRUhkkqbvGLEhDIupNLGOgm9EgDlqVAGG14Hz3DCKSZgxApFM164eCcCwI0ucDADobHy0sa6aQYmrTAupNLGurwiQIQJZVxIpY3LKwFEmFDGhRz1/XuCb/79/QcAAAA= because it does not appear in the font-src directive of the Content Security Policy.

[Error] Refused to load data:application/font-woff2;base64,d09GMgABAAAABNhQABIAAAAMKDwABNfZAAEAAAAAAAAAAAAAAAAAAAAAAAAAAAAAGowsG4fldByBpkI/SFZBUsNQP01WQVKBOgZgP1NUQVQkAIHAJC+CEAqImDiG9VULzzAAMJjyYAE2AiQDzywEIAWVEweC7GNb9K3bAUE+vbrZy/mugNzm6cJBbK1jtFZxU/TVlo+EhAL+NeKb2V8bDxLau1A2EJTE5p5J/89EKQ/1wDHUQXXI0AcCDYiuOvehOSAyxjYvV4gkbnbJbs3yUJsQPfv/////////////////////hpMfT7r1ZnZ35v+/jRCSEEgIYQ2EktCl9CMEqaIGCwIqaD/1LAfhRIkRYh3CiFHESJDCkLTPQQyElRz6kcfAQIFGKKZsgZRksDw0TCukqmwi7Ij4l9ZIOqoworl6f/9YVqo8YMyQaYxjAs45pmyMYZqaTEbMcI6dwsQ0kRmjLaFJ…tECkfKKQzVzaKy9w1ClW3V4HhbkisxjDjamor3DtuiUT5rlyRol6Vq9UavbfZbO3fr24UBaYRCkdTmpbVv56x4A2XQO2IAFk240mNAiDChTN10YBUzqWJWmbrZsOgMANLqudXonVSytEbA1p2gpNulB4VyqW296RhnLNOw9WZjvTlUMze1rTePqazO83k7dmaVuQ/j4HSxqZ3btt6+nACWeXkUnxK7uHa0fvEfaea9CCJMKONCKm2sqzcdIMKEMi6k6h2N3upOIMgFk7xk8nWqtzDRAOT6m/f/dw+pGoMLsZv4gV9r7igQLhl3e0dRnhsn5jDqHJ2aRIxFv94ewVOPBI+DPdqw4PRS9ZzUADrRqXnokOotAmpdgBAmlHEhlbG9xQCRTEGbepMRE8q4kEob6+pNAVg+FL614FwXAxfJ1BAwiUJpk4VbS00AHnD1WpgILZte2ljXGphEwbiQShvrFj7bRRBhQhkXUmnj6k0CiDChjAt56uuW4H9++/8/ because it does not appear in the font-src directive of the Content Security Policy.
[Error] [Report Only] Refused to load data:application/font-woff2;base64,d09GMgABAAAABNhQABIAAAAMKDwABNfZAAEAAAAAAAAAAAAAAAAAAAAAAAAAAAAAGowsG4fldByBpkI/SFZBUsNQP01WQVKBOgZgP1NUQVQkAIHAJC+CEAqImDiG9VULzzAAMJjyYAE2AiQDzywEIAWVEweC7GNb9K3bAUE+vbrZy/mugNzm6cJBbK1jtFZxU/TVlo+EhAL+NeKb2V8bDxLau1A2EJTE5p5J/89EKQ/1wDHUQXXI0AcCDYiuOvehOSAyxjYvV4gkbnbJbs3yUJsQPfv/////////////////////hpMfT7r1ZnZ35v+/jRCSEEgIYQ2EktCl9CMEqaIGCwIqaD/1LAfhRIkRYh3CiFHESJDCkLTPQQyElRz6kcfAQIFGKKZsgZRksDw0TCukqmwi7Ij4l9ZIOqoworl6f/9YVqo8YMyQaYxjAs45pmyMYZqaTEbMcI6dwsQ0kRmjLaFJ…tECkfKKQzVzaKy9w1ClW3V4HhbkisxjDjamor3DtuiUT5rlyRol6Vq9UavbfZbO3fr24UBaYRCkdTmpbVv56x4A2XQO2IAFk240mNAiDChTN10YBUzqWJWmbrZsOgMANLqudXonVSytEbA1p2gpNulB4VyqW296RhnLNOw9WZjvTlUMze1rTePqazO83k7dmaVuQ/j4HSxqZ3btt6+nACWeXkUnxK7uHa0fvEfaea9CCJMKONCKm2sqzcdIMKEMi6k6h2N3upOIMgFk7xk8nWqtzDRAOT6m/f/dw+pGoMLsZv4gV9r7igQLhl3e0dRnhsn5jDqHJ2aRIxFv94ewVOPBI+DPdqw4PRS9ZzUADrRqXnokOotAmpdgBAmlHEhlbG9xQCRTEGbepMRE8q4kEob6+pNAVg+FL614FwXAxfJ1BAwiUJpk4VbS00AHnD1WpgILZte2ljXGphEwbiQShvrFj7bRRBhQhkXUmnj6k0CiDChjAt56uuW4H9++/8/ because it does not appear in the font-src directive of the Content Security Policy.
[Error] Refused to apply a stylesheet because its hash, its nonce, or ‘unsafe-inline’ does not appear in the style-src directive of the Content Security Policy. (m-outer-93afeeb17bc37e711759584dbfc50d47.html, line 1)
[Error] [Report Only] Refused to apply a stylesheet because its hash, its nonce, or ‘unsafe-inline’ does not appear in the style-src directive of the Content Security Policy. (m-outer-93afeeb17bc37e711759584dbfc50d47.html, line 1)
[Error] TypeError: null is not an object (evaluating ‘e.map’)
ec (2.902d83df.chunk.js:2:1974512)
(anonymous function) (2.902d83df.chunk.js:2:1981308)
da (2.902d83df.chunk.js:2:1940469)
ac (2.902d83df.chunk.js:2:1975861)
pl (2.902d83df.chunk.js:2:1993425)
pl
(anonymous function) (2.902d83df.chunk.js:2:2012744)
dl (2.902d83df.chunk.js:2:1989894)
Qc (2.902d83df.chunk.js:2:1986025)
Qc
(anonymous function) (2.902d83df.chunk.js:2:1937210)
(anonymous function) (2.902d83df.chunk.js:2:2012744)
Yo (2.902d83df.chunk.js:2:1937156)
Ko (2.902d83df.chunk.js:2:1937091)
Gc (2.902d83df.chunk.js:2:1982608)
mi (2.902d83df.chunk.js:2:1954326)
mi
(anonymous function) (main.d88ce18b.chunk.js:1:21879)
u (2.902d83df.chunk.js:2:942794)
(anonymous function) (2.902d83df.chunk.js:2:942544)
n (2.902d83df.chunk.js:2:23348)
c (2.902d83df.chunk.js:2:23552)
promiseReactionJob
[Error] Refused to apply a stylesheet because its hash, its nonce, or ‘unsafe-inline’ does not appear in the style-src directive of the Content Security Policy. (inner.html, line 1)

Dear @lester.coyoy

Thanks for the suggestion. I have manually clear the cloud settings, and now I can sync. :slight_smile:

Appreciated!

1 Like

Oh this is very much related to my problem. I ran this command and now notifications don’t work anymore. I did not stop the server beforehand 'though.