Ubuntu server snapd installing 3.2.2?

Description

For some reason snapd installed v3.2.2 but according to the repo that’s not the latest release? Am I reading this wrong or updating incorrectly? I used sudo snap refresh rocketchat-server but it says it’s up to date. Shouldn’t I see v3.4.2?

Server Setup Information

  • Version of Rocket.Chat Server: 3.2.2
  • Operating System: Linux, Ubuntu 20.04 x64, arm64
  • Deployment Method: snap
  • Number of Running Instances: 1
  • NodeJS Version: v12.16.1
  • MongoDB Version: 3.6.17
  • Proxy: lighttpd

Ah… I think it’s because I’m on arm64 (https://snapcraft.io/rocketchat-server) and snapd says that is the most recent stable version. Wow, didn’t realize it was so far behind, what a shame.

Arm64 builds still aren’t fully in sync with amd64.

Someone else on our team has been building. Let me ping and see if will be able to build.

1 Like

Any word on this? It looks like maybe it’s been nearly 3 months since the arm64 build was updated.