The ios version cannot be logged in

ios system version is 15.3.1, app version is; server version is 4.5.0.
The android version and web version work normally, but ios has no response after clicking login on the screen where user name and password are entered, but if the wrong user name and password are entered, it will prompt an input error.
The user registration function of the ios version is normal.

The server is based on nginx + docker-compose, and the CDN is cloudflare.

Can anyone tell me what is happening? How can I provide more useful information?


Can you try logging in our open server to check if this is not server specific?

For reference, this issue may be related:

I don’t know if it’s because my service is installed in a subdirectory, so I fill in the server address in the ios like “https://***.com/subPath”.

Only the ios client doesn’t have any error hint, and after clicking it, there is no response, as if I didn’t click it. And android and browser are working fine, very strange. I can also see the login record for ios in the server logs, but there is nothing behind it.


I have same issue. I only dont have cloudflare between, since it is available over VPN.
Linux client works, iOS simply stops.

Did you manage to find solution?

tried to login to and it works.

Have you seen this document?

our open server always runs on latest version. So this is certainly a network or certification problem.

Does it fail to login in android too?

Some suggestions: The app client can turn on debug logs to make it easier to fix problems. Because now I can’t log in, and I can’t see any error message, the “Login” button is not responsive after clicking, that’s all. I believe it will be much easier if there is a log log for viewing or sharing on the app side.

Hum. This message was flagged as SPAM, just saw it now. Sorry :frowning:

That’s the problem right here. You should not use sub directory to serve Rocket.Chat:

Ok, thanks a lot. But the strange thing is that the Android app works fine: I can login and chat, does this problem only happen in the ios app?

I have the configuration as recommended.
No subfolder.

Not sure, really.

As sub directory is no longer supported, some features and integrations is no longer tested against this scenario, and it may eventually stop working properly and will not be fixed.

It’s probably some minor configuration somewhere

Feel free to direct contact me in our open:

and we can try to troubleshoot this.



i have the same issue which where discused before… this is my second instance the first runs fine. I could also login via the apple rocketchat app to

My config looks like:

  • Root Server (bare Metal)
  • Rocket.Chat Server Version: 4.5.0
  • OS: Debian 9
  • Deploy via Docker
  • One instance with one replica set
  • MongoDB Version 4.2 via docker
  • Login with the app on works so far

What i have checked…

  • If i use a browser the login works fine…
  • when i try to login in the app and use the right credentials … after i hit login nothing happens. .
  • if i use wrong creds i get an error that i use the wrong creds

I use apache2 as an reverse proxy … the relevant part of the config is…

<Location/> Require all granted </Location>

RewriteEngine On
RewriteCond %{HTTP:Upgrade} =websocket [NC]
RewriteRule /(.) ws://localhost:3000/$1 [P,L]
RewriteCond %{HTTP:Upgrade} !=websocket [NC]
RewriteRule /(.
) http://localhost:3000/$1 [P,L]

ProxyPassReverse / http://localhost:3000/

hi @Fexxes! Welcome to our community.

Me and @MilanG did some troubleshooting on this, and he was able to find what the issue was.

He was using TLS 1.3. when he downgraded it to 1.2, he was able to login using iOS.

Let me know if this helped you :slight_smile:


thank you for the fast reply. With Debian 9 comes apache2 in version 2.4.25-3+deb9u12. This version do not support tls 1.3

But i change the configuration from all to 1.2 but the problem still exists.

configuration in virtual host config:
SSLProtocol TLSv1.2 -SSLv3 -TLSv1.1 -TLSv1

I have a feedback that the login over the android app ist also not possible. I try the connection over the windows app and this works well. So its looks like that its only affekt the mobile apps.

Just to check, have you seen this doc, right?

This may be something with your SSL, as web and APP will still log in into insecure servers, while mobile app usually doesn’t.

1 Like


wow… sometimes the small things have a huge impact.

I was to write the i know the doc an i done everything in it. But only to be sure i started to write my config down and the modules which where needed. What should i say… if you do not enable “proxy_wstunnel” for apache2 than the webclient works well. But the mobile client need the module.

After youe question i find out that the module is not enabled. After i enable the module… everything works as expected.

Thank you for your time.

1 Like

That’s awesome! Glad you fixed it.

Not sure why the webclient was still working even without proxy_wstunnel. :upside_down_face:

By the way, we would love to have you at our Community Open Call next week :slight_smile:


I have same issue. I only dont have cloudflare between, since it is available over VPN.. .