Rocket.Chat's Community Open Call 🎤 Jan 19th, 2022 Join us!

Stuck with enabling Apps System for Marketplace

Description

Hi,

I didn’t find anything similar(i have been looking for it for few days now) to my issue so i opening new topic.

I have installed my instance on VPS server with Ubuntu 18.04 everything went well. Unfortunately, for some reason I can’t enable Apps, it’s stuck like that for long time(screen above). I’ve registered at cloud, I’ve added token. I’ve tried clearing cache, etc. I even reinstalled chat a few times, with no error and still no idea why it’s happening.
Does anyone had a similar issue?

Server Setup Information

  • Version of Rocket.Chat Server: 4.3.0
  • Operating System: Ubuntu 18.04
  • Deployment Method: tar
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: 12.18.4
  • MongoDB Version: 4.0.27
  • Proxy: apache2
  • Firewalls involved:

Any additional Information

Hi! Welcome to our forums :slight_smile:

I was able to replicate this. I’ll escalate with our team.

Thanks for pointing out.

Also, unless you have a great reason, I strongly suggest you into looking for a docker deployment.

Thank you for your replay.

I’m sorry if I got it wrong, but as I understand, I should wait for patch? I’m aware that it won’t be in next one but in future releases?

Unfortunately, at that point, I cannot change to docker. My team already started working on it, and I’m not sure if there is any quick way to move all data.

Hi!

Did you chosen to register your instance at the wizard?

I replicated this error only while chosing not to register.

I deployed an instance where I have chosen to register at the wizard and I did not face this problem.

I will get back here as soon as I have this figured out.

Thanks!!

Hi,

Yes, I did and after your replay now I did it again to check if it helps but still stuck.

I have registered server, registered on cloud, verified cloud account(also probably unnecessary, but I have set up OAuth I have seen somewhere that is needed). In Connectivity Services, I have added token, logged in to cloud.

I also did reset configuration(only for cloud etc. not whole) and set it up again few times already.

Thank you, I am waiting for your help.

Alright looks like this will fix this issue [FIX] App Framework Enable hanging indefinitely by geekgonecrazy · Pull Request #24158 · RocketChat/Rocket.Chat · GitHub

2 Likes

Hi,

I will wait for new update!

Thank you very much for help. :slightly_smiling_face: