Failure to reach servers from OVH instance


I have been using my registered starter instance which is deployed on OVH servers for a few months. Since April, I lost access to the marketplace, push notifications and I started getting a warning that my server’s workspace version is outdated (I am using latest 6.7.0). I am aware that this latter problem will be solved in the upcomming release. However, this is a solution for air-gapped systems, while mine is connected to the internet.

I tried unregistering my instance and since then I have not been able to re-register it except via the offline method. I have not touched my default iptables firewall config in months and I do not suspect my outgoing https traffic would be filtered by my own server.

It seems to me that API started blocking my server via its firewall or some blacklist. I wonder if anyone else has experienced this phenomenon recently, as I have not been able to find similar experiences on the forums.

Server Setup Information

  • Version of Rocket.Chat Server: 6.7.0
  • Operating System: Debian 10
  • Deployment Method: docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: 14.21.3 - x64
  • MongoDB Version: 5.0.18
  • Proxy: apache
  • Firewalls involved: iptables

Any additional Information

Latest logs when visiting the marketplace or attempting to register the instance via token or email:

{"level":50,"time":"2024-04-21T09:04:16.415Z","pid":1,"hostname":"a66f73449a59","name":"Rocket.Chat Apps","msg":"Error getting the app requests stats from marketplace 'The user aborted a request.'"}
{"level":40,"time":"2024-04-21T09:06:08.180Z","pid":1,"hostname":"a66f73449a59","name":"Rocket.Chat Apps","msg":"Unable to access Marketplace. Does the server has access to the internet? 'The user aborted a request.'"}

Other logs relating to connection issues:

{"level":40,"time":"2024-04-21T08:53:53.326Z","pid":1,"hostname":"a66f73449a59","name":"SyncedCron","msg":"Failed to send usage report"}

What version were you running before?

How many users?

What licence type is shown in your cloud panel?

I was running 6.5.0 then updated to 6.6.6 then 6.7.0 on its release day.
My instance contains 20 users and the licence type shown on the panel is Starter Seats with an Active status.

Not seen anyone blocked.

(Note - there is a very good reason to not use ‘latest’ in your compose file. ALWAYS set a specific version and upgrade when you are ready and have tested - I personally would never, ever, upgrade on day 1 of a new release)

What actually changed when you got blocked/lost connection? Was it an upgrade or did something else happen? Did you change anything on your server? Exactly when did it occur?

Okay, I get it that being an early adopter of new releases poses a risk on production systems.

Looking back at the backups, the update to v6.6.5 was on 22/03/2024. I haven’t noticed when push notifications stopped working but according to the push notification usage stats (below), they have not worked on April. Only this week we started getting the “unsupported version” warning relating to 6.5.0 which we moved away from way earlier this year.

Other than the version update, there were no other changes on the server. Is there a way for me to check if the API is accessible to me from the server? An http request sent via curl for example? Just to locate the problem (RocketChat version issue vs networking issue).

IIRC there is a bug open on Unsupported version.

However, not this bug first and check your server connectivity.

If that fails then open a thread in #support and I can ping the appropriate person to take a look. (You can’t DM me but I will be there)

Hello, @youcef!

We are sorry that you are having this problem.
Please run the command below on your database so the message can go away:
db.rocketchat_settings.remove( {"_id": "Cloud_Workspace_Supported_Versions_Token"} )

Let us know if it doesn’t work.
Best regards, Bárbara Zanella.

1 Like

@reetp @barbara.zanella after testing, both fixes, DB command or Update to 6.7.1, solve the issue of the unsupported version as I stated in the original post. However, my online system is still considered offline or air-gapped due to connectivity problems to RocketChat Cloud.

I will proceed by opening a thread on #support as recommended

Best regards

Someone will take a look over there in due course - please be patient.