RocketChat does not load on Setup-Wizard

Description

Hello, I have just installed RocketChat to our CentOS 7 test server a subdomain. When I load this: http://rocketchat.namhost.com:3000/setup-wizard the setup wizard does not load. And the rocket chat service does not want to connect with the domain name either here: https://rocketchat.namhost.com/home, as you can see SSL, is also installed to the subdomain. Here is what my config file looks like:


[Unit]
Description=Namhost Rocket Chat Server
After=network.target remote-fs.target nss-lookup.target nginx.target mongod.target

[Service]
ExecStart=/usr/local/bin/node /opt/Rocket.Chat/main.js
StandardOutput=syslog
StandardError=syslog
SyslogIdentifier=rocketchat
User=rocketchat
Environment=MONGO_URL=mongodb://localhost:27017/rocketchat?replicaSet=rs01 MONGO_OPLOG_URL=mongodb://localhost:27017/local?replicaSet=rs01 ROOT_URL=https://rocketchat.namhost.com:3000/ PORT=3000


I can also confirm that the rocket chat service is running:


MongoDB Version: 4.0.12
MongoDB Engine: mmapv1
Platform: linux
Process Port: 3000
ReplicaSet OpLog: Enabled
Commit Hash: 92c00dc3c2
Commit Branch: HEAD


I have no Apache errors, nor does rocket chat logs show any errors either for me to fall back on.

Server Setup Information

  • A version of Rocket.Chat Server: Latest
  • Operating System: CentOS 7 - InterWorx
  • Deployment Method: Manual Install
  • Number of Running Instances: N/A
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: v8.11.4
  • MongoDB Version: 4.0.12
  • Proxy: Apache
  • Firewalls involved: CSF

Any additional Information

When I telnet locally to port 3000, I do not get any response back to show that the connection is completing. Somewhere something is wrong with the configuration or so. See here:

[root@core ~]# telnet localhost 3000
Trying ::1…
telnet: connect to address ::1: Connection refused
Trying 127.0.0.1…
Connected to localhost.

Any assistance will be highly appreciated, thank you.

I may be experiencing the same problem:

Server Setup Information
A version of Rocket.Chat Server: Latest
Operating System: Ubuntu 18.4
Deployment Method: Manual Install
Number of Running Instances: 1
DB Replicaset Oplog: Enabled
NodeJS Version: v8.11.4
MongoDB Version: 4.0.12
Proxy: Apache
Firewalls involved:

Hi,

I have the same problem as well. The wizard doesn’t load, it just spins. Earlier this month we launched a rocket.chat server and didn’t have any issues. This new server is configured in the same way. At first I thought it might be our security groups (AWS) but I opened up everything, except 22, to everyone from everywhere and it didn’t change.

Problem on rocket.chats end?

Thanks

Karen

Hi,

Update:

I was able to install rocket chat on the new server by using version 1.3.2

Versions 2.0, 2.0 RC1-5 and the latest RC 2.1.0 do not load the install wizard.

Karen

Hi,

Thanks for your update @kburgen9

Did anyone find another solution than downgrading to an older version or when is this bug planned to be fixed?

Didier

Hi @didiwein,

I couldn’t find an alternative. I had to install 1.3.2 and then update. Actual had to update to the latest RC as I couldn’t get the live chat to work on version 2.0

Going forward I’m going to keep a separate dev environment just to make sure updates don’t break anything. I don’t see another way to use in production otherwise.

Karen

My solution was restoring from a server image and re-do the entire installation process. Also, with the initial install, which failed. I had no virtualhost created in apache2 and I had to create it AFTER the RC install. After I restored from our server image we made, I created the virtualhost first and then proceeded to install RC, it seems that may have been the fix.

Hi guys, if you open your developer tool (F12 in chrome) and go to the console tab do you get the error?

Failed to load resource: net::ERR_SSL_PROTOCOL_ERROR
cc945290c4dafe28d2516121de8ec1f7c477a095.js?meteor_js_resource=true:275

Uncaught (in promise) TypeError: Failed to fetch

Hi, in the initial reported post, the problem is that the ROOT_URL shouldn’t have the port 3000, since that is the URL as you will access it on your browser, then the proxy will forward traffic to the port 3000.

For the other cases, could you check that ROOT_URL in the systemd file, and Site_URL as you find it in the startup logs match the public URL (withourt the PORT)?

Thanks!

hey, this problem was introduced by this pr: https://github.com/RocketChat/Rocket.Chat/pull/15204 …
Since the version 2.0 we started to use dynamic imports, the main reason is reduce the load/parse timing on the client side… the problem is: meteor uses the ROOT_URL to fetch the dynamic bundles, so if you misconfigured the url the client will fail to fetch the setup wizard bundle…

I made this fix https://github.com/RocketChat/Rocket.Chat/pull/15432 as a workaround that try to fetch the bundle again using the relative url… but you probably should set this setting in a properly way

1 Like

The help page for this can also be found here: https://go.rocket.chat/i/invalid-site-url

I really appreciate your answer. To make it work I tried a lot things including the https://go.rocket.chat/i/invalid-site-url but I couldn’t figure out a way to remove the port from the Site_URL in the rocketchat.service status. Even dropping the database or restarting didn’t lead to the desired result.

If it helps here is my config file:

[Unit]
Description=The Rocket.Chat server
After=network.target remote-fs.target nss-lookup.target nginx.target mongod.target
[Service]
ExecStart=/usr/local/bin/node /opt/Rocket.Chat/main.js
StandardOutput=syslog
StandardError=syslog
SyslogIdentifier=rocketchat
User=rocketchat
Environment=MONGO_URL=mongodb://localhost:27017/rocketchat?replicaSet=rs01 MONGO_OPLOG_URL=mongodb://localhost:27017/local?replicaSet=rs01 ROOT_URL=https://mydomain.com PORT=3000 OVERWRITE_SETTING_Site_Url=https://mydomain.com
[Install]
WantedBy=multi-user.target

Thanks for your time!

Update:

I finally found a solution. I removed the port over the db by executing the following commands:
mongo
use rocketchat
db.rocketchat_settings.find({"_id":“Site_Url”}).pretty()
db.rocketchat_settings.update({"_id":“Site_Url”}, {$set: {“value”: “https://mydomainwithoutport.com”}})

Check your browser :slight_smile:

2 Likes