RocketChat suddenly fails to load (or stay running)


I ran into a brick wall recently, as in a few hours ago. I have RocketChat installed through the Digital Ocean droplet install. I had my droplet up and running, and patched to the latest version. I have a custom domain attached ( that resolves to the droplet (VM), and then the built in traffic to route the inbound 443 SSH traffic to the app within the VM. Basically stock install of the droplet, and using Lets Encrypt as the encryption provider. All worked well up through about noon; when I launched the site to reply to a message, I received a “Bad Gateway” message. In a nutshell, rocket chat wasn’t running. Tried to start it, and it launches for about 30 seconds (in the process monitor; the site never comes up) then fails and closes.

Server Setup Information

  • Version of Rocket.Chat Server: I think 5.1.0. It was the latest version before 5.1.1 was just released (I can’t get it to load to look).
  • Operating System: Ubuntu 20.04.5 LTS
  • Deployment Method: Digital Ocean App Store Droplet (
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Not sure how to determine
  • NodeJS Version: 14.18.3
  • MongoDB Version: 5.0.6
  • Proxy: traffic
  • Firewalls involved: ufw

Any additional Information

Logs are attached in a text file, as the message system won’t let me copy and paste here due to multiple links embedded in the logs.


Sorry for the delay here. Missed this thread somehow :frowning:

Were you able to solve this?

Frank, I have had a similar problem on a similar installation. Debdut Chakraborty on the Rocket.Chat #support channel suggested a solution that seems (thus far) to have worked for me. He wrote:

Open /lib/systemd/system/rocketchat.service file. You’ll see a section like this


Might be more than one. You can safely remove those lines. Leave the other Environment lines be.

Then restart the process.

1 Like

Good morning! Thanks for the reply. I ended up restoring the snapshot of the machine (I lost some data, but it is what it is) to the previous version and have it up and running.

Thanks, Geomas. I ended up restoring to a previous machine image; however, with your info, I’ll attempt the upgrade again this coming weekend, and see if the file edit you mention clears up the issue. I’ll post back when I try and let you know if it worked. Thanks again for the reply!

Frank, as it turns out, after I posted my reply to you, the Rocket.Chat service again quit unexpectedly (though the server itself did not crash). However, after that I updated my instance to version 5.1.3, and thus far, after 1 day and 6 hours, the Rocket.Chat service has not failed. :crossed_fingers:

1 Like

Got it. I’ll try the same this weekend and let you know how I make out. Thanks!

1 Like