setup wizard won't get past pg 1 Docker setup on Ubuntu 18.04


I’m testing using the docker script available from

The only items I changed were the ROOT_URL which I set to my local server I’m testing. ROOT_URL=

When I get to the setup wizard on I can fill in name, username, email, password and click on Continue. Continue turns light blue and the process just hangs. I’ve tried this on Chrome and Firefox

I’ve checked all the docker logs and everything seems to be running normally. Any ideas?


Server Setup Information

  • Version of Rocket.Chat Server: 3.4.2
  • Operating System: Ubuntu 18.04
  • Deployment Method: docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: 12.16.1
  • MongoDB Version: 4.0.19
  • Proxy: none
  • Firewalls involved: ufw turned off

I did check the post where there seemed to be a similar issue: Can't get Setup Wizard to progress beyond 'Step 1' - 'continue' button does nothing

But changing the email had no affect on the lack of progress of the setup wizard

Anything in browser logs or server logs at all? This sounds kinda like a client side issue

I have the same problem, no way to pass setup wizard page 1. ’ve tried this on Chrome, Firefox and Edge.

Like mozartatplay I used the official docker-compose script and only changed the ROOT_URL variable.
I tried on my Ubuntu 18.04 server and on google cloud Ubuntu 20.04 virtual machine. When I load the setup wizard page, I insert the data and press the continue button the page freezes. If I try to reload the page the normal login page appears, but obviously there is no user to log in.

I have recreated the containers many times and tried to access the setup page from chrome, firefox, edge from my desktop, my laptop and (chrome and firefox) from my android phone.

My logs:
LocalStore: store created at
LocalStore: store created at
LocalStore: store created at
Setting default file store to GridFS
ufs: temp directory created at “/tmp/ufs”
Loaded the Apps Framework and loaded a total of 0 Apps!
Using GridFS for custom sounds storage
Using GridFS for custom emoji storage
Updating process.env.MAIL_URL
Browserslist: caniuse-lite is outdated. Please run next command npm update
(node:8) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use th
e Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
➔ System ➔ startup
➔ ±--------------------------------------------------+
➔ ±--------------------------------------------------+
➔ | |
➔ | Rocket.Chat Version: 3.5.4 |
➔ | NodeJS Version: 12.16.1 - x64 |
➔ | MongoDB Version: 4.0.20 |
➔ | MongoDB Engine: mmapv1 |
➔ | Platform: linux |
➔ | Process Port: 3000 |
➔ | Site URL: http://X.X.X.X:3000 |
➔ | ReplicaSet OpLog: Enabled |
➔ | Commit Hash: ef234790be |
➔ | Commit Branch: HEAD |
➔ | |