Black screen on /setup-wizard


I stood up new instance of rocketchat on our server and when I went to use the setup wizard I see the inital content for a split second then the screen goes black. If I refresh the page the conent never loads, it sits with animated elipses. This behavior is the same across machines with chrome and when using the windows desktop client.

Server Setup Information

Server Setup Information
A version of Rocket.Chat Server: Latest
Operating System: Ubuntu 18.04.3
Deployment Method: Manual Install
Number of Running Instances: 1
DB Replicaset Oplog: Enabled
NodeJS Version: v8.11.4
MongoDB Version: 4.0.12
Proxy: Apache
Firewalls involved:none


Description=The Rocket.Chat server
ExecStartPre=/bin/sleep 60
ExecStart=/usr/local/bin/node /opt/rocket/Rocket.Chat/main.js
Environment=MONGO_URL=mongodb:localhost:27017/rocketchat?replicaSet=rs01 MONGO_OPLOG_URL=mongodb:localhost:27017/local?replicaSet=rs01 ROOT_URL=https:chat.domain.tld/ PORT=3000

systemctl status rocketchat.service

● rocketchat.service - The Rocket.Chat server
Loaded: loaded (/lib/systemd/system/rocketchat.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2019-09-21 20:19:31 UTC; 20h ago
Main PID: 3047 (node)
Tasks: 10 (limit: 9466)
CGroup: /system.slice/rocketchat.service
└─3047 /usr/local/bin/node /opt/rocket/Rocket.Chat/main.js

MongoDB Version: 4.0.12
MongoDB Engine: mmapv1
Platform: linux Ubuntu Server 18.04.3
Process Port: 3000
Site URL: https:chat.domain.tld:3000/
ReplicaSet OpLog: Enabled
Commit Hash: 92c00dc3c2
Commit Branch: HEAD


<VirtualHost *:443>

ServerAdmin administrator@domain.tld
ServerName chat.domain.tld
ErrorLog /var/log/chat.domain.tld_error.log
TransferLog /var/log/chat.domain.tld_access.log
LogLevel info
SSLEngine On
SSLCertificateFile /etc/letsencrypt/live/chat.domain.tld/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/chat.domain.tld/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf

Order allow,deny Allow from all

RewriteEngine On
RewriteCond %{http:Upgrade} =websocket [NC]
RewriteRule /(.) ws:localhost:3000/$1 [P,L]
RewriteCond %{http:Upgrade} !=websocket [NC]
RewriteRule /(.
) http:localhost:3000/$1 [P,L]

ProxyPassReverse / http:localhost:3000/

I found the source of the prolem:

As detailed above in the rocketchat.service output the Site URL: https:chat.domain.tld:3000/ still held the port number. When I corrected the service file to ROOT_URL=https:chat.domain.tld/ PORT=3000 I must have forgotten to drop the mongodb rocketchat database to flush the old value.

Once I stopped the service, flushed the db, and restarted the service it started working correctly.

1 Like