Can't get Setup Wizard to progress beyond 'Step 1' - 'continue' button does nothing

So I’ve setup Rocket.Chat following the Ubuntu / Docker install guide here fully (Ubuntu Server 19.10 is the running OS). It seems to be working, and all reports back good based on the commands I run in the instructions.

However, when I go to, when I fill out the first page of the setup wizard (with Name, Username, Organization Email and Password all complete), the ‘Continue’ button becomes blue, but clicking on it goes nowhere. There are no reports on the web page that I’ve entered anything wrong and have tried many combinations of different entries, reboots of the hosting VM, etc. I’ve also tried with multiple different browsers on multiple different systems.

To add, on one occasion it worked, but then wouldn’t let me change the email address of the admin account I created, so I rolled it back to the prior snapshot and it refused to work again, even though everything was as it was the time it did work (as far as I could tell). It has me really stumped.

Would really appreciate any thoughts anyone has. Cheers!

OK - looks like it doesn’t like the account (at least the initial admin account) to have an email address at the same domain the server itself is part of. A bit odd, but perhaps it will become clearer as I work through getting the server setup. If any developers who work on Rocket.Chat are reading this, there was no indication of what the problem was when trying to continue off the first page - perhaps a future version could have an explanation pop up to inform the user what the issue is, instead of literally not doing anything? Many thanks