Rocket.Chat docker server running but page stuck on the three dots loading page

I tried to sudo mongo, but it says:
“./mongo: error while loading shared libraries: cannot open shared object file: No such file or directory”
Is there anything wrong with my snap?

I also had to install the ubuntu-desktop on the server and once that was done I was able to use localhost:3000 and saw everything was running properly. then I went in the settings ,General and changed the site url.

But the Port must be icluded in the Site URL in Setting, yes?
for example: http://myserver:3000

Tried to include the port? (https://yourdomain:3000)

Yes, I believe so as well

It’s does help. I tried your solution and it worked!
Thanks a lot !

No problem, glad I was able to help!

It works!
Btw, add port number to the end of the site_url if necessary.

Nothing here is working for me. Neither in snap nor docker, still stuck with the 3 dots. I think it’s time to move on to Mattermost considering that absolutely no one here should be required to go through the problems that so many are going through.

I don’t know if any devs read these forums, but if they do, perhaps release working versions instead of making the entire community your alpha/beta testers. I can only imagine how much money they are raking in doing techincal fixes and support.

I’ve been having this issue as well and finally got it resolved.

Running snap install (6.4.5) on ubuntu

I had also previously set the
sudo snap set rocketchat-server siteurl=

But that did nothing on its own, without the additional mongo setting below.

The issue is the Site_Url setting in mongo, but all examples weren’t working for me. Not sure why mine is configured this way, maybe it’s that its a very old install, but hopefully no matter how yours is setup, these steps will allow you to find and fix the issue.

First to get into a snap shell run ‘sudo snap run --shell rocketchat-server’
Then you can run ‘mongo’

Once in mongo, run ‘show dbs’

My issue is that my install did not name the database ‘rocketchat’, but mongo doesn’t complain if you attempt to use a nonexistent db, I assume it thinks you are wanting to create it.

When I ran ‘show dbs’ I saw 4 dbs:
rs0:PRIMARY> show dbs
admin 0.000GB
config 0.000GB
local 1.047GB
parties 0.527GB

So first I tried ‘use local’
Then I ran ‘show collections’, it showed some replset, system collections. So likely mongo related stuff.

So at a whim, I did ‘use parties’, and ‘show collections’, and holy c***, rocketchat collections, including the rocketchat_settings collection that the other post have been speaking of.

I did the
db.rocketchat_settings.update({“_id” : “Site_Url”},{$set:{value:“”}})

checked it with
db.rocketchat_settings.find({“_id” : “Site_Url”})

That didn’t seem to work immediately, so I rebooted the server for good measure, and WooHoo!! It worked.

Not sure if the database name was something I changed years ago when I installed it or what, but maybe this will help someone else out as I haven’t seen these instructions on any single post out there, had to get info from many different web pages to figure it out had to do this on a snap install.

Hope this helps.

1 Like

I just did a fresh ubuntu manual install rocketchat 6.4.8 , same problem with 3 dots.

I am happy it worked out for you and perhaps others can follow along with your solution and it will fix their issues. I may play around with RC in the future, but for now, I’ve moved to Mattermost and it worked out of the box on the first install.

Try this

run mongosh and use rocketchat then type this db.rocketchat_settings.update({"_id" : "Site_Url"},{$set:{value:"<YOUR URL>"}}) and sudo systemctl restart rocketchat.service

I tried the Site URL approach, but it did not work for me.
Thanks to
db.rocketchat_settings.find({“_id” : “Site_Url”})
I saw, that to whatever reason, my url was not only written in the value field but also in the packageValue. I am not a mongo guy, so bear with me.
But after I also changed the packageValue to my url, it worked for me.

This fixed the issue for my snap install running 6.5 edge. What is strange is when I checked the db.rocketchat_settings, the site url was in both spots and nothing looked out of place. After rebooting several times the issue with 3 dots loading persisted until I ran your command: db.rocketchat_settings.update({“_id” : “Site_Url”},{$set:{value:“["}})

After a reboot of the server, the site loaded, and I was able to proceed with configuration. Thanks again for the help.

I have the same problem, but I am trying to run it on Kubernetes, with the Rocket.Chat supplied Helm chart.

The rocketchat and MongoDB both do not show any errors. Yet the webpage is only the three dots, trying to load something that never does.

Managed to change the site URL with above method, and now it works.

I think the Helm chart should do better then this.