Rocket.Chat can not receive SMS texts from Twilio. (Twilio's Debugger: HTTP retrieval failure)

(This has been solved please read at the bottom for what fixed the issue.)

I am having trouble receiving Twilio’s SMS texts from Rocket.Chat’s LiveChat

In the admin panel on I put in the correct Twilio’s “ACCOUNT SID” and “AUTH TOKEN”

I also put the correct webhook details on Twilio’s “A message comes in”:

I followed the details from:


RocketChat: How to send SMS Messages to Livechat channel from mobile

I have Rocket.Chat server running on a Raspberry Pi 3+ B model with Raspbian Buster OS.

Im using ngrok to tunnel and able to access my server on the web when using the ngrok http url.

Twilio’s Debugger shows “HTTP retrieval failure Error 11200”

I also have tested this on Ubuntu Server on raspberry, same exact problem as above.

Please view the pictures below:


This has been solved thanks to Alan’s comment: “Don’t put the port 3000 on the Ngrok URL (. You tell Ngrok what port to send to your app via the configuration and you just send to the Ngrok URL using HTTPS or HTTP.”

On Twilio’s ‘Message comes in’ webhook URL, I removed port “:3000” from “” and it solved the problem.

The proper webhook URL syntax that solved the issue is: “https://your_rocketchat_url/api/v1/livechat/sms-incoming/twilio”

1 Like