Quoting doesn't work on my rocketchat server; it just makes a rocketchat picture and no quote

Description

Ok so I am not allowed to upload an image to show…but whenever I or any other member tries to use the quote function the text never shows and you just get a default bubble showing the rocketchat logo and the server and domain name.

I looked online and couldn’t find anyone else facing this issue so don’t know what is wrong in my case?

1 Like

Did this happen to happen in a group dm? Or what kind of room? Also what version? Is this a new bug with the release you just went to… or did it appear earlier.

I had something like this happen once but haven’t been able to narrow it down to report

It has happened for the duration of the server. I installed the server back in May I believe from your site from docker image and updated it only the other day and still the same issue, never been able to have quotes working.

I just presumed they were not implemented as this was the case with discord when we used that some years ago but reading around the other day I realized this is a bug rather than the norm as others reported quotes working fine and the website docs too.

In the info tab it says version 3.0.12 now but sorry I don’t remember what it was before update, however I know the issue persists regardless of the version I have used.

No not group dm. We have both public and private channels/groups and irrespective of which the behavior is the same in both.

Quotes definitely are supposed to work. I use them daily. One quick thing to check is make sure ROOT_URL is set to the address you use to access Rocket.chat. Might be that easy of a fix.

If not… Can you run this query on database:

This will spit out all settings that have changed. Filter out any credentials or domains. But would be good to see settings to see if maybe related to settings.

1 Like

Well the root_url is the domain but is set http and we use https, will that make a difference (I have setup nginx to redirect http to https if that matters)?

Where do I run that query? is it a mongodb thing? I have been unsuccessful running any mongo commands thusfar as I was trying to do so for the pruning thing the other day and when in the mongo container I would not be able to get to mongo shell, it would say failed to contact mongodb. I am going from memory here as it was a few days ago but that was the gist as I recall.

It being http probably would actually make a difference. I’d try fixing that first.

With docker compose it usually is a matter of doing something like: docker-compose exec -it mongodb mongo

Ok I just changed the ROOT_URL to https and rebooted and no change so I shall try the latter…

Sorry how am I supposed to run the code you gave above?

docker-compose exec -it mongodb mongo just shows the arg options and docker-compose exec -it mongodb mongo get-settings-changed.js (having saved the contents to file) also brings the same output of only the arg options, nothing is run.

As I said mongo stuff is alien to me :).

which docker-compose file did you use? I can provide a bit more detailed example :slight_smile:

Was facing the same exact issue in RC 3.5.1 (hope I remember it correctly). I don’t have the instance anymore so can’t provide any more details here.

One information that I can provide though, is that the “RocketChat picture” is actually a link to the particular message being quoted. If followed it’ll point to that specific message. You can test this by disabling link previews in settings, and it’ll all go away (i.e. virtually “quoting” and “just messaging” will be the same).

Edit: The problem also persists on a RC 3.5 deployment (the same version is deployed and used in my workplace, and quoting works flawlessly). So this isn’t a 3.5.1 bug as far as I can tell.