Rocket.Chat can't quote messages, instead it shows a the logo and url

Hello,

I noticed a few threads with this topic but haven’t been able to find any resolution. Is it possible to get some ideas on how to resolve the issue below?

Description

When a message is quoted by a user, the quoted message shows up on chat as a Rocket.Chat logo and the URL. I’ve tried a previously mentioned solution to ensure the site URL was set as my site’s URL, but that didn’t resolve the issue. The server starts up running https://chat.domain.com as the default site URL.

rocketchat_quote_issue

I should also mention my current server is running behind an Nginx reverse proxy, which is serving it without issues. I’m not sure if there’s anything specific that should be configured on it to allow quoting to work correctly.

Server Setup Information

  • Ubuntu 18.04 LTS server
  • snap installation (snap installation - snap install rocketchat-server)
  • Rocket.Chat version - 3.5.2
  • Site URL is https://chat.domain.com not localhost

Any insight would be appreciated.

Thank you.

3 Likes

I Fix this issue by change site url form http to https in Administration>General

my Rocket Chat Version 3.10.3

hope this help

1 Like

Thank you for the trick.
I changed that configuration in my different servers and now it’s working.

For anyone curious about this, it’s because quotes aren’t actually quotes. They’re attachments where the content of the attachment contains the permalink of the quoted message. If the URL isn’t right, it can’t find the original message when it’s time to render the attachment.

I found this out when I had to alter the quoteAttachment code to make it obey the Use Real Names config setting.