Push notifications not working


#1

Hi all!
I installed Rocket.Chat server ver. 0.65.1 from snap on Debian 9 and use apache as a proxy.
After this i checked push notifications with native android app from play market (ver 2.3 i think) and they was worked. But then android app was upgaded to ver. 2.4, notifications stoped working.
I guess this happend because developers went from GCM to FCM model of push.
Has anybody this problem too?


#2

I believe it did change from GCM to FCM. But from all of our testing it has continued to work.

In your push settings on the server are you using the push gateway still?


#3

No, in start using rocket chat, i disable a gateway and push work fine.


#4

If you use our apps from the play store. Push is not going to keep working with out the push gateway.

Basically if you want push… and you use our apps you’ll need to use the push gateway.


#5

Yes, we are using yours app from play store. Ok, now i drop to default push settings (gateway https://gateway.rocket.chat is enabled) and tested push - system said push was successfully sent, but on smart i not received any notification.


#6

You may need to restart your server after enabling. If that doesn’t work logging out on the mobile and back in should re-link it up.


#7

Yes, after restarting push is worked.
Thank you!