Cannot get android push notifications to work


#1

Hi all
I’ve just installed Rocket Chat using Snap and it was extremely easy! I’ve also installed the android app on my Samsung phone but I cannot get the notifications to work. If I send a message to my account from another account I expect to get a notification on my phone. If I open the app and look at the list of channels I can see a number which tells me there is a new message.
I’ve read many articles about push notifications and it seems that it should just work now without setting up anything else but still no joy.
I am using Rocket Chat 0.65.1 on my own Ubuntu 18.04 server installed using Snap. My android app is version 2.2.0 build 2021.
Does anyone have a clue what I have done wrong or can I provide any more information? I must have missed something in the setup but I have read and reread the documentation. It does say in the docs that I should setup Firebase but other messages say that isn’t needed when using the stock android app.
Thanks in advance for any help.
Mike


#2

Did you build the app from source or using our app from the store?

Also did you change any of the push settings?


#3

Hi Aaron. Thanks for your suggestion.
I used the stock app from the store and the stock snap with no alterations.
Interestingly, having left it over night, I just tried to send a message to it and I received a notification! However, when I tried that again I did not receive one. Is there some sort of delay or maximum number of notifications that will be sent?
Sometimes it seems to send them but not always which is strange. Is there some sort of logic to decide when to send a push or is it all the time? Does the app have some logic to decide when to display a notification or is that all decid3ed by the phone?
I’m afraid I’m not an Android developer so I don’t know enough about how the OS works and whether it affects things.
It’s only a minor problem though as the rest of Rocket is briliant!
Mike

Mike


#4

So one thing to be aware of… if you have your account up in the browser or desktop client until that connection is considered idle, push notifications will not go to your mobile. This is typically what happens for most


#5

I have issues with this too.
I’m running 0.65.1 from source. Haven’t configured Push (it’s marked as Disabled) and running stock Android app from Play Store.
I have just closed the Desktop client, and verified from some other user that I’m “Offline”. Starting a private conversation with my user does not trigger a notification on my Android.
Opening up the Android app shows the conversation as highlighted and unread.
Edit: I reset the Push-section and see that I was not running the default.
Running “Test push to my user” now still says “Push disabled” even though it is enabled.
Also, we might have a firewall blocking outbound connections from RocketChat.


#6

This would be an instant breaking factor. :slight_smile:


#7

About that: What exactly is sent to the gateway? We are looking at using RocketChat on-prem for internal use, and we can’t have anything leaking.
Is there something we can do to avoid using a gateway at all?


#8
  • Compile your own apps with your own push credentials.
  • Disable sending message with push.
  • Don’t use push notifications

#9

Is it possible to get notifications on the mobile app without push? So that the app would poll every 5 minute or so?


#10

I believe there is investigation underway for doing some encrypted notifications. But polling in background is not something I think in consideration. Battery is too precious and we don’t want to be the ones eating it up


#11

I’ve a similar issue. I’ve installed rocketchat from snap, and I can build the android app from source, and replace services.json to my own. The problem is that the mobile app uses Firebase Cloud Messaging. On the server I should set GCM api key and project id, but in FCM there are only a server API key. How should I setup my server for FCM?


#12

I had a an issue along the same lines, if you are reverse proxing it, through nginx or apache
I dont use the snaps since im on centos but this may help not sure.

Nginx
https://github.com/RocketChat/Rocket.Chat.Android/issues/1050 (not tested i use apache)

apache
add to your httpd config file for rocketchat
LimitRequestBody 0


#13

In FCM you don’t have a project id? You can use in the gcm fields


#14

I’m having the exact same issue. In https://console.firebase.google.com for my project, Under settings -> General I have :

  1. Project name
  2. Project ID
  3. Web API Key
  4. Public facing name

PLEASE can you advise exactly which fields to put into Rocket Chat under:

  1. GCM API Key
  2. GCM Project Number

Our IOS push notifications works perfectly, but Android does not work at all.

Many thanks in advance


#15

Please make sure you restart Rocket.Chat after making these changes.