Push notifications not working...again

#1

So on top of the pile of other issues I’ve been having with Rocket.Chat, I have recently noticed that push notifications aren’t work either. I have attached the log output below.

rocketchat:logger server.js:199 e[31mSystem ➔ error Error sending push to gateway (2 try) -> { Error: getaddrinfo EAI_AGAIN gateway.rocket.chat:443     at Object._errnoException (util.js:992:11)     at errnoException (dns.js:55:15)     at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:92:26)   code: 'EAI_AGAIN',   errno: 'EAI_AGAIN',   syscall: 'getaddrinfo',   hostname: 'gateway.rocket.chat',   host: 'gateway.rocket.chat',   port: 443 } 

Is this project dying? I’ve been having some pretty deal breaking issues since setting this up and these forums seem almost dead, the sub Reddit is almost dead…googling any of these issues finds posts or bug reports on github where the issue was either never solved, never solved “properly”, or seems to have been solved and magically popped back up a year later.

I want to like Rocket.Chat…but this is not off to a good start.

#2

Switched to the Ubuntu Snap install instead of Docker and it works fine now.

#3

You probably ought to visit https://open.rocket.chat

At a guess it was probably a DNS Issue looking at this :

Error: getaddrinfo EAI_AGAIN gateway.rocket.chat:443

At a guess your docker networking was awry, or your proxy setup. Those are the two most common issues.

#4

I had the same issue on my Docker + Traefik + Rocket.Chat setup. The fix was to enable DNS resolver in /etc/default/docker.

# Use DOCKER_OPTS to modify the daemon startup options.
DOCKER_OPTS="--dns 1.1.1.1 --dns 1.0.0.1"

Before applying the fix, I shelled into my RC container and couldn’t execute a curl command due to it timing out.