Problems with the integration of Jisti in Rocket.Chat


I have a Rocket server.Chat v5.4.5. I would like to install the jitsi application on it GitHub - RocketChat/Apps.Jitsi: Rocket.Chat App for Jitsi from the zip file. I used the instructions from the official website there was a problem on “Agree to the permissions needed to complete the installation.” when I try to give consent, I don’t get any result, I click on the button and nothing happens.

Server Setup Information

  • Version of Rocket.Chat Server: 5.4.5
  • Operating System: Debian 11.4
  • Deployment Method: tar
  • Number of Running Instances: 1
  • DB Replicaset Oplog: wiredTiger (oplog Enabled)
  • NodeJS Version: v14.20.0
  • MongoDB Version: 4.4.16-16
  • Proxy: nginx
  • Firewalls involved: no

Any additional Information

In the logs /var/log/nginx/access.log, when I click consent, I see the following message

<MY_IP_SERVER> - - [19/Jul/2023:18:37:24 +0300] "POST /api/apps HTTP/1.1" 400 81 "" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:102.0) Gecko/20100101 Firefox/102.0"

Please help with advice or ideas on how to solve the problem.

We decided to install the application from the command console

rc-apps deploy --url http://localhost:3000 --username <username> --password <password>

also unsuccessful, gives an error

   Starting App Deployment to Server

   Getting Server Info... ✓
2023-07-21 14:54:16.504 WARN  App has external module(s) as dependency
   Packaging the app... ✓
   Uploading App... ✖
 ›   Error:    ⟿  Error: Deployment error: Direct installation of an App is disabled.

At the same time, developer mode is enabled in my settings. What could be the problem?

It helped

systemctl restart rocketchat.service