Connect with Jitsi Server, self hosted

Hi, I am a bit confused.
I am self-hosting a rocket chat server, and I do have a self-hosted jitsi server. Within the Rocketchat server I stored the JWT credentials to access the jitsi server.
Since the upgrade to 5.5 I all of the sudden do need a market place account to do nothing more than that.

There is a “learn more” link, that leads to , which shows me a “page not found”.

I don’t really get it. Do I have to pay for the possibility to connect those two services from now on?

Hi, can you check if this procedure below helps?

Honestly, it is getting worse.
Last year I convinced some customers to switch to rocketchat. Each one of them now did the cloud registering, downloaded the Jitsi extension, and inserted their settings data.
Just updated to Version 6 (using Ubuntu/snap).
Now all settings concerning Jitsi have disappeared.

Docs say:

Go to Administration > Apps > Marketplace.

There is no “Apps” in the menu any more.

When trying to do a call with a participant, it says conference calls have not been configured, use the Jitsi App.

When clicking on “Settings”, there is a dropdown that says “empty”.

Am I the only one who is left with disbelief?
I have to say, the combination of Jitsi + Rocketchat has been a dream, until now.

Add. screenshot from my testing machine

Noticed we have following tickets on github:
-Jitsi not enabled · Issue #28594 · RocketChat/Rocket.Chat · GitHub
-Jitsi not working in Enterprise hosted · Issue #28935 · RocketChat/Rocket.Chat · GitHub

We are working on improving the experience of apps. Sorry for the inconvenience.
Please check if 28594 helps and if not, let me know here as I try to expedite solution for 28935