Oops your credentials were rejected! Im the administrator trying to login with my own account

I have ubuntu snaps rocket chat server.
I can login using desktop pc no problem.
When i install rocket.chat mobile app for android, i cannot log in using any account in rocket chat. It throws the same error with them all…

oops your credentials were rejected! Please Try again.

My bloody credentials are correct…how else can i be logging in on desktop pc?

Any ideas on WTF is wrong with the app?

hi @adamjedgar

just to make sure, when you downloaded the app, on the first screen have you added your server (typing the server address) or have you clicked “join the community”?

I’m in the same boat. I can log in over cell network on a mobile browser but not with the app.

I’m entering my http:/myip:3000 at the server selection screen and receive a password prompt. However, neither of the accounts I’ve created will connect.

1 Like

An interesting development.

I can access my server through the app IF using an account created through the app. Any pre-existing account is getting denied.

I’m experiencing the same issue @diego.sampaio any development on what the issue might be? I am using https://rc.seekingalpha.com as my server URL. thanks.

Was there any solution for this? I’ve just experienced the same issue with the Android app for my existing admin account. I even tried to disable two-factor authentication to see if it was that.

Mine is a Snap running on Debian. I turned info on in logs but nothing is shown indicating an error. I do have new registrations turned off, but that should not be an issue as I’m an existing user.

Further info: I also had a test user I created after my admin users (with no admin rights). Oddly enough that one logged in fine on the Android app. When I switched back to trying to login with my admin user, same error. Only difference I can think of was the test user never had 2FA activated. But admin user, with 2FA disabled, still can’t log in.

I seem to have sorted the issue out now. One thing I did was change my password to something a bit simpler without many special characters.