Cannot login via mobile app android


i cannot login from android app, login via web is ok also via windows application but from mobile i have no messages in logs or “wrong user” in the app.

where to check ?

Server Setup Information

  • Version of Rocket.Chat Server: 4.6.2
  • Operating System: Ubuntu 18
  • Deployment Method: snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: v14.18.3
  • MongoDB Version: 4.2.17 / wiredTiger
  • Proxy: apache
  • Firewalls involved:

Any additional Information


Welcome to our forums.

Usually, the mobile will require a HTTPS/SSL connection to the server.

Can you confirm your deployment does have it?

This doc may help you on in case you don’t have it:


Yes i confirm the access is via httpS protocol (tcp/443)

The https access via browser is perfect also via windows application (that call the https URL)

The only problem is join via Android App there’s no evidence in the logs

How to troubleshoot ?

Assuming you have the latest version installed on this Android device.

Please, check if you can access our open server in, so we can isolate the problem on your deployment.

I have seen this kind of error when it comes to TLS versions too old or too new, not playing nicely with the underlying Android version.

Also, it may have some firewall on the middle blocking it, or some reverse proxy not properly configured.

Here we have a doc about how to properly configure a reverse proxy:

is this snap server publicly facing the internet and the one responsible for the SSL?

Also, consider not using snap.

Our suggested deployment method is docker or k8s.

there’s a procedure to backup only chat history and attach files but not the configuration (we can start from zero) ad migrate to a clean install on docker or k8s ?


yes we can access to open server without problem.

No firewall blocking (we have check no drops on logs)

We have followed the reverse proxy guide for Apache and via web browser and via application (installed on windows) all works

What we can check for TLS ? or what you suggest next?

Here you can have the procedures to backup snap:

Here you can check the TLS of your server:

yes the check reports 1.3 enabled , 1.2 enabled, then 1.1 and 1.0 disabled

just to make sure, you pointed it to your server, right?

Yes exact i pointed to my server

That’s really strange.

Can you increase the log verbosity (Admin > Logs) and then check if there is some related logs to this user while trying to login in Admin > View Logs?

My bet is that this is some configuration, and it’s not even hitting Rocket.Chat at that point for the Android App.

Do you know if there is any WAF rules along the way?

Hi there, solved !!!

i don’t understand how i missed it, in reality the fault was the reverse proxy, the a2emod passage for the webservices was missing, so the app from the mobile phone that uses them. The login (via app) that takes place via https then was rightly unable to communicate with the webservices because the reverse proxy didn’t know how to behave.

thanks to all for support


Glad you solved it. Thanks for sharing :slight_smile: