Roadmap Reveal 🗺 What's next for Rocket.Chat, Sep 22

Not receiving emails anymore so cannot change settings as admin as TOTP is required

Description

Server Setup Information

  • Version of Rocket.Chat Server:
  • Operating System: Linux
  • Deployment Method: docker
  • Number of Running Instances:
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy:
  • Firewalls involved:

Any additional Information

I had the SMTP settings correctly enabled before but in order to disable the welcome emails users get (despite the setting being switch off) I removed the SMTP settings but unfortunately now my admin account isn’t getting the 2fa codes sent to email when I try to change other settings.

Is there a way I can set the SMTP settings again or disable the 2fa?

By the way, I don’t know why 2fa is enabled for the admin even though I’ve disabled 2fa in the app.

Hi there!

You can overwrite this option by setting some environment variables, such as:

  - OVERWRITE_SETTING_Accounts_TwoFactorAuthentication_Enforce_Password_Fallback=false
  - OVERWRITE_SETTING_Accounts_TwoFactorAuthentication_Enabled=false

You can change almost all configuration using this technique.

You can also change directly from the database, if you know how to do it:

please, let me know if this worked for you.

Thanks!!

1 Like

Hey thanks for your response!

Unfortunately I ended up just resetting my server by deleting all rocketchat collections

1 Like