RC standalone doesn't send emails and requires 2fa! It's the loop!


Please, help!
I’ve installed standalone RC. But in cannot send emails (i didn’t receive any), but requires 2fa via email!
How can I exit this infinite loop — disable 2fa via email or setup email WITHOUT 2fa via email?!

Server Setup Information

  • Version of Rocket.Chat Server: latest
  • Operating System: Ubuntu 20.04
  • Deployment Method: docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog: ?
  • NodeJS Version: ?
  • MongoDB Version: ?
  • Proxy: no
  • Firewalls involved: no

Hi! Welcome to our forums!

You can overwrite all settings by adding this to your docker-compose.yml enrionment on rocketchat service:

  • OVERWRITE_SETTING_Accounts_TwoFactorAuthentication_Enabled=false

then, after restarting the server, it will disable 2FA.

let me know if this works for you.


I’m not very familiar with SSH or other terminal apps… can you please tell the commands to do this?

Hum. Ok.

1 - after logging into the server
2 - you will need to change the docker-compose.yml for your installation, at services > rocketchat > evironment
3 - with that accomplished, you will need to run, at the same folder where you will find docker-compose.yml:

docker-compose up -d

steps 1 and 2 you can use some windows tools for that. for step 3, it would go something like this:

ssh user@server.com.br
cd /where/docker/compose/yml/is
docker-compose up -d