Error SMTP configuration and problem with two-factor authentication



I was setting up a new smtp provider and failed in the configuration.

Now to modify the configuration I am asked for two-factor authentication by email.

But I can’t receive the code.

What can I do?


Server Setup Information

  • Version of Rocket.Chat Server: 5.1.2
  • Operating System: Debian
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy:
  • Firewalls involved:

Hi! Welcome to our community :hugs:

You can disable the two factor authentication if you have access to the admin page.

if you don’t have access, but still have access to the server, you can disable it by passing an environment variable, like such:
OVERWRITE_SETTING_Accounts_TwoFactorAuthentication_Enabled: false

Let me know if this helps or you need further assistance.