Live Chat issues

I installed Rocket.Chat via snap on a LXD container and I use haproxy as a TLS proxy. Rocket.Chat seems to work fine (I’m very new to Rocket.Chat), but I can’t figure out how to deploy Live Chat.

I’ve enabled Omnichannel and pasted the Livechat Installation script in the footer.php of a WordPress site. A little square renders in the lower right corner, but in that sqaure it says Firefox cannot display the content. Specifically, “To protect your security, will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window”. Even opening that little square in a new window does not allow the live chat function to work.

Any ideas? Thanks very much.


Server Setup Information

  • Version of Rocket.Chat Server: 3.5.2
  • Operating System: Ubuntu 20.04
  • Deployment Method: snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy: haproxy
  • Firewalls involved: iptables directing to haproxy

Have you tried the Wordpress plugin for Rocketchat

Works perfectly for me and no need to add the script.

hey tonyb70 could you help me please

I’m sorry @surendrababu.s not something I am able to help you with, I’m no expert in this field.

Ok Thanks TonyB70 if You dont mine do have any documentation of backup and restore using docker ?

@TonyB70, thanks for replying. Yes, I tried the Wordpress plugin, and it behaved exactly the same way. In fact, I tried the plugin first and thought it just wasn’t working for me.

This makes me think that there is something wrong with my Rocket.Chat implementation, but it seems to work fine.

I did notice that within my Rocket.Chat implemenation when I go to Ominichannel > Livechat Installation, the script presented has URLs of https://localhost/. I changed them to, but is that expected? Might there be other parts of the code that I should be changing?

Thanks very much, again.

Have you got ‘Restrict access inside any Iframe’ disabled in the General settings? That caused my problem in the end with the Wordpress plugin.

It should of listed your correct URL not localhost as I understand it.

@TonyB70, yes! That did the trick! Thanks. But… The chat window that pops up does not have a cursor or a text window to type. Any other ideas? Very exciting to get this to work, almost.

Sorry to say I don’t, I had to do a reinstall only to find that was my issue all along with the wordpress plugin.

I don’t have my install done via snap as I have mine running on a plesk docker install which I get cheap from digitalocean so not really sure I can help much more.

Ok, thanks again. I appreciate it.

Can I ask below the Restrict access inside any iframe. What is written in the box, is it Same Origin?

Not sure if that is not there might be a problem also.

Apart from that I don’t have any other ideas.

Yes, specifically it says “sameorigin”.

Last thing I can think of. Are you just using the WP plugin or the install script or both at the same time on the Web page?

:slight_smile: I had to look. Only the plugin.

Then sorry fresh out of ideas on my end.

Thanks for trying.

But I have a simple question. I see that there are connections between Omnichannel and Livechat, but documentation is so unclear. Are they the same? Is Omnichannel the new Livechat? Is Omnichannel something totally new? And where can I find good documentation of Omnichannel/Livechat? Thanks again.

In case anyone else has ideas on this, the chat box that renders when one clicks the Livechat icon in the lower right hand corner of my site does not present any place to type text. It’s just a white background with a blue bar at the top that sayes “Leave a message”. But one can’t type in the box anywhere.

Any ideas how to get this to present a text box? I feel like I’m so close to getting this to work.


Omnichannel is the new name for live chat.

I was unable to find any documents for it other than the basic use of it.

Can you put a screenshot of the chat box that you see on the Web page from the WordPress slide.

Thanks for looking at this.

@TonyB70, I’m sorry, I just rebooted the Rocket.Chat server and it’s now behaving much more as I would expect. Thanks for taking the time to look at this, but I think it might be ok now. I’ll do some testing. Thanks again.