Fresh installation on Ubuntu 22.04 and SNAP rocketchat install will not show page (Meteor issue)

Hi Everyone

As I have an old 4.x Rocketchat installation and several failed upgrade tries I decided to start fresh and install on my proxmox server an ubuntu 22.04 server VM and use SNAPS to install Rocketchat.
I made sure to also set the siteURL via SNAP command line and I see the correct internal IP when using “snap get rocketchat-server”

So far so good I thought. I restarted using the SNAP command and then tried to access the page from my machine (the server is headless, no GPU) but the result is endless loading.

When analyzing the calls done I saw that one file want to be called still from localhost:3000! It seems to be a Meteor related file.

So I checked the meteor_runtime_config.js file and was shocked to still find a reference to localhost:3000 in there:

I tried for hours to install rocketchat on many multiple machines from my local one to a VM on the local machine to several different ways on using snap during the installation of ubuntu server using the rocketchat option to manually using the SNAP. Easily lost 2 days because of this. I never managed to get a running rocketchat system without this behavior!

So how can I change the ROOT_URL in this metor config js file? And why is it not using the siteurl value configured?

And no, I do not want to use Docker so please try to solve the actual issue :slight_smile: . I don’t want to use it. I have a huge Proxmox server where I want to run them isolated like this and do different snapshot scenarios. And I want one thing less to care of and maintain.

Thanks a lot for guidance in advance

I had the same issue I resolved it by doing the following (This example will assume you’re also wanting to use SSL)

ensure ports 443 80 and 3000 are open if you’re using ufw for the server firewall by the following

sudo ufw allow 80

sudo ufw allow 443

sudo ufw allow 3000/tcp

sudo ufw reload

The URL is by default set to http://localhost:3000 and to confirm this you run the following

sudo snap get rocketchat-server

This will list the variables you can alter, in this case we need to change the siteurl, to do this we use snap set (we will also omit the :3000 at the end)

sudo snap set rocketchat-server siteurl=https://<>

Once this is done we will enable caddy

sudo systemctl enable --now snap.rocketchat-server.rocketchat-caddy

sudo restart rocketchat-server

Then it should be a matter of browsing to the server URL

However this will still leave http <> : 3000 open, I haven’t figured out how to resolve that issue. You need port 3000 open on your external firewall to use mobile apps and also 3000 on the server to run the rocket chat service. If you know how to resolve that issue any help would be great.