Rocket.Chat's Community Open Call 🎤 Jan 19th, 2022 Join us!

Error upgrading to 4.2.2 (latest stable) from 3.18.3 by snap

Description

Server Setup Information

  • Version of Rocket.Chat Server: 4.x/stable
  • Operating System: Ubuntu 16.04.7 LTS
  • Deployment Method: snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy: reverse proxied through Caddy
  • Firewalls involved: no

Any additional Information

Tried to upgrade today but got the below error. Anybody know how to fix it?

root@HOMESERV:/var/snap/rocketchat-server# sudo snap refresh rocketchat-server --channel=4.x/stable
error: cannot perform the following tasks:
- Run configure hook of "rocketchat-server" snap if present (run hook "configure": [ERROR] "http://localhost:3000" is not a valid url)

I also try it on clean state after reinstall rocket-chat server and got same error.

Hi! Welcome to our forums!

Please, what commands have you executed?

Have you followed any doc?

Have you seen this doc? Updating Rocket.Chat snap to 4.x track

Also, I always suggest docker, as it’s easier to maintain, update and get help around.

Thanks!

Yes I’m followed by this instruction.
First time I use both command (sudo snap refresh rocketchat-server and sudo snap refresh rocketchat-server --channel=4.x/stable ) on work instance and got error.
Then I delete rocketchat via snap delete command and install new clean version by comman snap install. It’s by default install 3.18.3 version, I checked that its worked and then try swith to 4.x channel and got the same error.
One more thing is that wheni got error than command “snap info” show that installed 4.1.2 version. And the main proccess cannot start, starting only mongodb proccess.

hum.

cc @debdut.chakraborty may be able to help you.

But please, consider moving to docker.

@pavelmk could you please show us the output of ls /var/snap/rocketchat-server/ -l ? Thanks.

Also the whole output of snap info rocketchat-server