Customizing version 5.0.0

Hi, Im trying to customize RC version 5.0.0
So I got the source code from here.
And followed the instructions for development found here.
When I run the app with the command “meteor yarn dev” its logs seem fine, just as when I did with previous versions. But when I try to access to the app with the browser I can only see a gray screen.
I also tried building the app and then running it with docker-compose and the same happens.
Is there a fix for this issue? Is there any additional step for developing with the new version?
Thanks in advance.


We would need more log in order to understand what is going on =\

Hi. Thanks again for reaching out. I just saw yo answered in github issues to my post here.
What other information would be usefull?

Maybe in adition to the github issue I made. the following info is usefull:
I did manage to get version 5.0.0 working from Rocket.Chat’s repository via docker.
But since I need to make some changes to the source code I need to run and build for develop.

The Docker is the built product, so you need to be able to run it from source, then build it.

I was able to check from source, and after running:

yarn build
yarn dev

I end up with a working Rocket.Chat running from source code =\

It will take some good amount of time at the first build, but its working. We need to figure out why you were not able to run it first.

I’ll try again then from scratch. Could it be because of some config inherited from my previos version? We use RC embeded in an Iframe.

Also I have another question. This regardin to the meteor, yarn, node and npm.
Should I install node, npm and yarn besides installing meteor?
What I did no not mix up versions is using the commands to use meteor versions like this:
meteor npm install yarn
meteor yarn
meteor yarn build
meteor yarn dev

Worked ok starting from scratch. I really dont know what the problem was but it’s fixed.
Thanks a lot

1 Like

Just in case it is usefull. The version I downloaded today works fine from scratch. The one I was trying to run before was downloaded back on the release day. And it still shows a gray screen when runing it. I don’t know if it was changed from the release day or not.
However you were very helpfull. Thanks again


You should not download the source, bur rather clone it from github using git.

With that you can checkout specific branchs or tags. the develop and main branches usually holds the latest commits, that are usually grouped into versions, according to their tags

Good advice. I thought it would be easier to just download the source code, and start from there, since we do not use github but bitbucket.