Trouble: yarn run dev exited (129) when setting locally

Description

Hi. I’m new to Rocket Chat. I’m currently trying to setting Rocket chat locally on my system but I am facing some issues.

I am getting the error message below when I’m running ‘yarn dev’ using the node version as mentioned.

So kindly can you please guide me on how to resolve this issue?

Server Setup Information

  • Version of Rocket.Chat Server:
  • Operating System: Windows 11 64bit
  • Deployment Method:
  • Number of Running Instances:
  • DB Replicaset Oplog:
  • NodeJS Version: 14.19.3
  • MongoDB Version:
  • Proxy:
  • Firewalls involved:

Any additional Information

Hi!

Just to make sure: you are trying to learn more about Rocket.Chat in order to develop and change code, right?

I asked that, because if want to only used it in your company or organization, this is the path you should follow: Docker & Docker Compose - Rocket.Chat Docs

with that sad, A good place to hang and ask questions about it, is here, where some developers using windows usually hang out:

let me know if this helps!

Thanks!