Cannot enable push gateway

Hi everybody !


I have got an issue to enable push gateway.

  • It is a self-hosted server
  • It is connected to the Rocket chat cloud service
  • I used the “sync” button multiple times
  • In Admi => push, what I did :
    • Disable push notification, restart rocket chat
    • Enable push notification, restart rocket chat
    • Try to unable push gateway but it was a gray inactive button
    • Click on button “reinitialize section parameters”
    • Save and restart the server

Now, the “activate push gateway” and “production mode” buttons look likes to be “enabled”, but they still gray / inactive.
When I click on the “send notification to the user”, it does not work.
And I still have the red banner about notifications.

It was working before the enforcement of notification registration… :’(

Server Setup Information

  • Version of Rocket.Chat Server: 3.5.1
  • Operating System: 1.16.0
  • Deployment Method: snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Activated
  • NodeJS Version: 12.16.1
  • MongoDB Version: 3.6.14
  • Proxy: caddy

Thank you for your help :slight_smile:

This seems to be an issue when upgrading to 3.5.1 using snap:

Hi ardentheart,

I did not check the agreement of cloud service ><

Thank you for the link.

Have a good day