Cannot access workspace from the Web after unexpected popups


Hi and happy new year to you all!

I’m running my own instance of Rocket chat on a server at DigitalOcean using Snap. It has been working fine in the past few days. Yesterday, when accessing my instance via a Web browser, I saw a popup asking me whether my workspace was new or an upgrade (can’t recall exactly the text now) several times. I selected upgrade because my workspace was not new and, frankly, I didn’t understand what the popup was about.

My instance was working fine after that. However, after reopening my Web browser this morning, I cannot access to my instance via the Web. All I can see are these “three dots”. I can still access it via the mobile app though. The mobile app says Version and Workspace version 6.5.0. I tried to go into the Admin panel via the mobile app and all I can see there, too, are the three dots. (Probably because the Admin panel of the mobile app. is just a view of the Web page?)

Could someone please help me fix this problem?

Server Setup Information

  • Version of Rocket.Chat Server: 6.5.2
  • Operating System: Linux
  • Deployment Method: Snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Don’t know
  • NodeJS Version: v14.17.3
  • MongoDB Version:
  • Proxy: Nginx
  • Firewalls involved: No

Any additional Information

I couldn’t access the info. from the UI because all I can see are these “three dots”. I used the command line and did: sudo snap info rocketchat-server, which seems to show that my instance was upgraded automagically from 6.4.1 to 6.5.2, is that correct? Could that explain the problem that I’m seeing?

name: rocketchat-server
summary: Rocket.Chat server
publisher: Rocket.Chat (rocketchat✓)
store-url: …
contact: …
license: unset
description: |
Have your own Slack like online chat, built with Meteor. …

  • rocketchat-server.backupdb
  • rocketchat-server.mongo
  • rocketchat-server.restoredb
    rocketchat-server.rocketchat-caddy: simple, disabled, inactive
    rocketchat-server.rocketchat-mongo: forking, enabled, active
    rocketchat-server: simple, enabled, active
    snap-id: wdBUbiEuMNHmAHLBCXQXOcXaOCvbWS1e
    tracking: 6.x/stable
    refresh-date: 2 days ago, at 18:27 UTC
    6.x/stable: 6.5.2 2024-01-04 (1599) 361MB -
    6.x/candidate: ↑
    6.x/beta: ↑
    6.x/edge: 6.5.2 2024-01-04 (1599) 361MB -
    latest/stable: 6.4.1 2023-10-16 (1580) 354MB -
    latest/candidate: ↑
    latest/beta: ↑
    latest/edge: ↑
    5.x/stable: 5.4.10 2023-05-19 (1556) 301MB -
    5.x/candidate: 5.4.4 2023-03-09 (1540) 300MB -
    5.x/beta: 5.4.4 2023-03-09 (1540) 300MB -
    5.x/edge: 5.4.10 2023-05-19 (1556) 301MB -
    4.x/stable: 4.8.7 2022-12-04 (1533) 281MB -
    4.x/candidate: ↑
    4.x/beta: ↑
    4.x/edge: ↑
    installed: 6.5.2 (1599) 361MB -

So, I reverted to the previous minor version and now I can access my instance just fine. Reverting from 6.5.2 to 6.5.1 solved my problem. Could there be a bug in 6.5.2?

What I did:

sudo snap revert rocketchat-server
2024-01-06T23:04:20Z INFO Waiting for “snap.rocketchat-server.rocketchat-mongo.service” to stop.
rocketchat-server reverted to 6.5.1

Any suggestion regarding this possible bug?

I wonder who could help me with this?