Website live chat widget integration not working


Server Setup Information

  • Version of Rocket.Chat Server:
  • Operating System: Ubuntu 20
  • Deployment Method: Snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy: none
  • Firewalls involved: UFW

Any additional Information

Not sure how to get the version of nodejs and mongodb since i installed the rocket chat server by snap.

Anyway I was successful with the installation, and I was able to point my browser (Firefox) at http://ip_addr:3000 to configure rocket chat. After that, I copied the embed widget code and pasted it into my test website.

The widget didn’t appear. Checking with the built-in debugging tool shows the following error message: “Error: Promised response from onMessage listener went out of scope background.js:835:170”

I double checked with Chrome and the widget didn’t appear, either.

Any ideas? Thank you very much.


Can you check if http://ip_addr:3000/livechat is working?

I assume ip_addr is a publicly available ip, right?

Also, make sure to have this website also configured in Admin > Omnichannel > Livechat > Livechat Allowed Domains


Thanks for your reply.

I am testing now. It’s sitting in a VM box on my computer, and their IP are in 192.168.1.x. I can see the “home” page and “Omnichannel” page fine. The “livechat” page is currently blank, but when it’s loading I could see some words at the top left hand corner of the page for a fraction of a second.

As for the “Livechat Allowed Domains,” the box is currently empty, which apparently allows all domains.

Thanks for your help!

If you open your developer tools at the browser you are using to visit http://192.168.1.x:3000 your should see some errors that may help on this issue.

Also, make sure to have http://192.168.1.x:3000 as your siteurl (Admin > General) considering that this is the ip of the vm you want to access it “externally” from within your own network.


Thanks for your reply. After setting the siteurl in Admin>General, the “livechat” page now works fine. :grinning:

Pointing my browser at http://192.168.1.x:3000 works as well. It redirects me to’s home page.

It’s the embedded embedded widget on the test website - which is just a page with some pseudo latin in /var/www/html of my computer - still doesn’t work.

For chrome, the error is “Refused to display ‘’ in a frame because it set ‘X-Frame-Options’ to ‘sameorigin’.”

For Firefox, the error is “Error: Promised response from onMessage listener went out of scope ‘background.js:842:170’”

I hope that’s helpful.

Have you tried explicitly filling the field “Livechat Allowed Domains” with the domain or ip you are trying to use?

looks like the server is not allowing it.

Awesome! That did the trick. I wonder why?

Thank you very much indeed! :+1:

I believe that help text is wrong. :see_no_evil:

I have already raised this internally and we’ll work on it.

Thanks for pointing out! :slight_smile:

Please, consider also joining our Community Support Channel to help other and get help too.

And also check out our upcoming monthly Community Open Call or past sessions