Video conferencing Jitsi

Description

Recently, we enabled Jitsi Video conferencing option on RocketChat for private channels. The issue is the conference session is not timing out or the same session is using on future calls even after 5+ hours. Is there any way to set the Jitsi session timeout in RocketChat to avoid the same session being using for all calls? If yes, that would be much helpful.

Scenario:

  • I have started a video conference call on a private channel, and all online staff got alert about the call.

  • Closed the call session after 15 minutes of meeting

  • Later after 5+ hours, I started one more video call in the same channel but no alert came in users end and they had to click on the same old Join button to get into the conference call.

  • I then asked one of the other staff to start a conference call, and when he did no one get the alert and had to use the same old Join button to get into the conference he started.

This isn’t suitable for a production state. I guess the old conference session is not getting timeout even after closing off the call. I probably would be missing some thing, or it could be a bug.

Any help would be much appreciated! :slight_smile:

Server Setup Information

  • Version of Rocket.Chat Server: 2.4.0
  • Operating System: CentOS 7
  • Deployment Method: rocketchatctl
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: v8.17.0
  • MongoDB Version: 4.0.17
  • Proxy: No
  • Firewalls involved: CSF, but no issues with it.

Any additional Information

1 Like

A similar situation on the 3.0.0 server version.
But users can click the Video call button on their own, and join the call.
This is not convenient, and in my opinion - the most correct option is to always create a new invitation.

Are you using the official Jitsi Server, or a self hosted one? If selfhosted, check if the problem still occurs when using Jitsi in a browser without RocketChat integration.

I’m on the similar situation.

Description
When creating a new meeting, RocketChat won’t redirect the user to the created meeting. It would just get stuck on that pop window to join that meeting. For the users to join the meeting, they would have to click “Call” again; creating another alert of a new meeting. The expected response, from my understanding that is, should be that RocketChat will open a new pop up window (new tab) for Jitsi Meet.

Setup

  • RocketChat: 3.14
  • OS: Ubuntu 20.04
  • Deployment: Docker | Self-Hosted
  • Node: 12.22.1
  • MongoDB: 4.0.24

Jitsi is also self-hosted and is working perfectly on its own. I even used “meet.jit.si” as well thinking it might be the way that our self-hosted Jitsi requires a login. However, the issue persists.

Has anyone found a solution for this yet?

Please check github and release notes.

I think you will find some Jitsi issues were fixed in 3.15 and possibly more to come.

1 Like