Upgrade from 5.0.0 to 5.0.1 broke Twilio outgoing SMS over Omnichannel

Had completely successful upgrade from 5.0.0 to 5.0.1 and since then the out going SMS isn’t working anymore and the phone number isn’t showing. I figured the 5.0.2 update would have fixed it, as well as the 5.0.3 but to no avail. The SMS Omni channel was working wonderfully not sure why we changed it. It catches incoming just fine and I have verified the Twilio side doesn’t receive anything


Server Setup Information

  • Version of Rocket.Chat Server:
  • Operating System:
  • Deployment Method:
  • Number of Running Instances:
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy:
  • Firewalls involved:

Any additional Information


The only changes from 5.0.0 to 5.0.1 are those ones

I don’t see any changes in the code related to this feature.

Have you tried to rolling back to 5.0.0? As it doesn’t have migrations, you should be fine.

Issue for reference: Outgoing SMS Using Twilio Broke In 5.0.1 upgrade from 5.0.0 · Issue #26566 · RocketChat/Rocket.Chat · GitHub

I’m currently experiencing the issue on 5.0.0. I was trying out rocket.chat on the digitalocean droplet and had the sms twilio integration working fine. The upgrade to 5.0.0 was when sms no longer connected with twilio.

Incoming webhooks seem to lose something as well as all sms messages turn into independent guests (no association to previous messages sent by the same from:number).

4.5.4 has Rocket.Chat/twilio.js at 4.5.4 · RocketChat/Rocket.Chat · GitHub

5.0.3 has Rocket.Chat/twilio.js at 845f56e37d2e922582b0433cd2972d76493b767b · RocketChat/Rocket.Chat · GitHub

The only difference seems to be the settings import.

@keeler Yes, all the new incoming ones show up on guests on mine too. VERY CLEARLY this is a bug, multiple people are having the same issue. I hope it gets fixed.

I have added my system details to the github issue.

From the github issue. There is a PR merged and planed to land in 5.1.0 here:


Are you aware that you can change Rocket.Chat’s tag name from the docker image and try the latest development branch?

If you could test it in your staging environment and feed us back, it would help a lot!

Also, consider joining our Beta Testers Channel