SSL Install Help- Unable to access via URL


Installed using DigitalOcean 1-click droplet. Followed the instruction here:
(Rocket.Chat | DigitalOcean Marketplace 1-Click App)

“Rocket.Chat will not work with HTTPS out of the box because certificates are unique for each installation, but with this setup HTTPS will be available using Let’s Encrypt certificates. After the Rocket.Chat One-Click is finished and your domain is setup. You will need to login to your droplet to finish setup.”

Using: ssh root@your_droplet_ip
I completed the install and also completed the setup wizard and the install works correctly.

I can successfully login via-
(http: droplet-ip:3000)
(http: url:3000)

UNABLE to access via (https: url) , receive error: ‘refused to connect’.
UNABLE to access via mobile, receive error: 'failed to connect to -url- and lists ip:443.

Completed A record and pointed to droplet-ip, which I believe is working correctly given I can access the sign-up page via (http: url)

Which leads me to believe this is an SSL installation issue. The DigitalOcean document reads that the SSL installation happens automatically if the A-record is pointed to the droplet-ip.

But there are 2 other RocketChat docs that have a much more involved installation procedure:

I am familiar with the domain/DNS settings, and was able to get the installation complete using ssh root@your_droplet_ip, but past that the other documents explaining the more advanced SSL installation is a bit past my scope.

Any help or guidance in how to bridge this last gap in deployment would be so greatly appreciated.

Thank you!!

Server Setup Information

  • Version of Rocket.Chat Server: Rocket.Chat 6.3.4
  • Operating System: Ubuntu 20.04
  • Deployment Method: DigitalOcean 1-click droplet
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy:
  • Firewalls involved:

Any additional Information