Some SMTP settings missing


Can’t get outgoing emails running. Several fields missing from SMTP settings section

Server Setup Information

  • Version of Rocket.Chat Server: 4.3.1
  • Operating System: Debian
  • Deployment Method: docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog: yes
  • NodeJS Version: 12.22.8
  • MongoDB Version: 4.4
  • Proxy: nginx
  • Firewalls involved: pfsense

Any additional Information

This is what the settings should look like (from the docs):
Email Configuration - Rocket.Chat Docs
Sorry, I tried to paste a picture but the system only allows me to paste one and so I had to choose…

This is what my settings look like (there is a lot missing - sorry for the German language, I couldn’t find where to switch it to English): STMP settings from instance

Resetting the section did not help.

How do I get all the other settings back?

Many thanks in advance!


That’s weird. I just went into that same options and they were all there, slightly different from the doc regarding design, but the fields were there.

I tested in 4.3.2 with English.

Can you please set it to English so we can make sure it’s not a translation thing? You can go to your avatar (top left), My Account > Preferences > Language. STMP settings from instance English

Doesn’t seem to make a difference :frowning_face:

So - anything I can try?



Have you tried different browsers?

Also, can you deploy latest version on a similar version and check if this is also happening?

And lastly, could I do a remote access to take a close look?

That’s a very intriguing issue.

Using a different browser helped.

I am not sure that it is a problem with the browser per se: The issue I have is with MS Edge. And using Firefox helped. However, after a couple of changes to the settings I also had the setting “Pool” disappear in Firefox. Deleting all website data in Firefox brought it back. So maybe it has to do with cached parts of the website?

Thanks for your help!

Good to know that ut worked.

But it’d be even better if we can get some information to our product/engineering team :slight_smile:

@rocketwolfe can you try and see when the setting options are disappearing, if you’re seeing anything on the console or not?

The more logs you can get us the better :smiley:


Sure, I can try.

Can you please specify which console (inside Rocketchat or the Linux console)?


The browser console & the server logs, both would be super helpful!

under RC 4.5.0 and newer the error is gone…

1 Like