SMTP Settings not working


#1

Hey everyone,
I have a question regarding a fresh installed rc-server. I entered valid smtp email settings and tried to send me a test email. But the only thing I’ve got is this notification: Error - Error while trying to send an email: Greeting never received. The first part is my translation. Anyway, no matter what smtp settings I enter, I always end up getting that message. When I google it, I find different problems, some regarding to an old issue with the nodemailer, some regarding to an old bug with the release candidate from last year. I hope you guys can help me. Here are my specs and logs:
I am using the snap container, so it should be up to date: 0.69.2 and Node version 8.11.3

[34mI20180924-15:32:56.336(2) Sending test email to …
[34mI20180924-15:32:56.342(2) The $MAIL_URL is ‘smtp://…:465’. You probably want ‘smtps://’ (The ‘s’ enables TLS/SSL) since ‘465’ is typically a secure port. undefined
[34mI20180924-15:33:28.351(2) Sending test email to …
[34mI20180924-15:45:27.730(2) Sending test email to …
[34mI20180924-15:53:55.683(2) Updating process.env.MAIL_URL
[34mI20180924-15:54:00.167(2) Sending test email to …

I also tried smtps, of course, but then I get: Mail command failed.
If you have any ideas, it’s much appreciated!
Best,
Heye


#2

We’re doing IP auth to our inhose smtp gateway and it worked without issue. Maybe try that first? I left username/password blank and just put the IP address in the host field.


#3

Thanks for the advice bbrendon. But I don’t see a setting like this in rocketchat and the smtp server I use is not inhouse. So I can’t setup anything there. The error message always comes with a certain delay, let’s say between 10 and 15 seconds. So I think it might be the result of a time-out. So I temporarily disabled the firewall, but nothing changed. What am I missing? What am I doing wrong here?


#4

I would set up a small local mailer such as ssmtp as proxy to your smart relay. So you can configure RC without any TLS and ssmtp does the TLS transport to your smart relay. I use sendmail as local mailer (only listening on localhost), so you have a full local log file of outgoing emails and better logging in case of email problems.


#5

I know it’s been a while, but I was quite busy. I thought about the sendmail solution, but something inside me didn’t want to go there. I mean, if nothing helps I will do it. But my problem is the following:
rc + mail provider = not working
nextcloud + mail provider = working
Neither rc nor my mail provider can tell me why. So I came to test different providers and gmail works. I’m not entirely happy with that combination, but for now it does the job.
I just wanted to let you know that I found a workaround. And for those who are experiencing similar issues: try another mail provider
Best,


#6

Yes, the mail configuration is a source of eternal joy. Personally I would set up a small mail server on the Rocket.chat server, e.g. ssmtp under Linux and send the mails unencrypted to this local mail server and then handle the forwarding via a smart relay. This is especially with regard to STARTTLS much less burdened with problems and as a side effect you have a nice mail log file.