SMTP Settings, can't make it work

Hi,

I managed to install the docker image on an existing server with Apache as a Reverse proxy and letsencrypt certificates.

Almost everything is working good so far except I can’t setup the smtp. I have a working email server and whatever setting I use I have errors. I can connect/receive/send emails with my email clients (laptop, mobile, webmail), I can use my email server with other applications (mattermost, wordpress, etc.) but not with Rocket.Chat. My email server certificate is self signed. Looks like RC doesn’t like that but I can hardly use a Letsencrypt certificate. I tried ports 465 and 587 (both are working with my thunderbird email client), I tried smtp and smtps, ignoreTLS or not, pool or not (although I’m not sure I understand what are this 2 settings for).

Any help would be appreciated

Chag

Have you tried to set up a small mail service on localhost and use your smtp from there via smart relay? This is what I do.

Hi @localguru,
Thanks for your answer. You mean, i’d better install a smtp server with all the settings related (dns, dkim, certificates, etc.) because rocket chat can’t connect to an existing postfix mail service ?

I’m using the docker image, do you know how can I modify it to install mail server ? I already have my mail service installed on the server but not on the docker.

A local smtp service delivers mails to a smart relay like a smtp client. Take a look at ssmtp for example. DKIM etc. does not have to be installed for this.

And test your RC with another SMTP server.

@localguru thanks for you answer.
Do you know how to install and setup an smtp service on the docker version ? or have any idea where I can find some documentation ?